Bug 1264029 - [Doc] Bonding modes 0, 5 and 6 should be avoided for VM networks - bring in from 6.7 docs
[Doc] Bonding modes 0, 5 and 6 should be avoided for VM networks - bring in f...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Virtualization_Deployment_and_Administration_Guide (Show other bugs)
7.2
All Linux
high Severity high
: rc
: ---
Assigned To: Platform Virt Docs
network
: Documentation, Triaged
Depends On: 1097143 1097312
Blocks: 1075802 1173188 1095589 1286552
  Show dependency treegraph
 
Reported: 2015-09-17 07:06 EDT by Laura Novich
Modified: 2016-01-26 21:00 EST (History)
30 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1097143
Environment:
Last Closed: 2015-12-20 03:40:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 67546 None None None Never

  None (edit)
Comment 5 Dan Kenigsberg 2015-11-17 06:09:37 EST
(In reply to Jamie Bainbridge from comment #4)

> > Under no circumstances should Modes 0, 3, 5, or 6 be used.
> 
> I assume this comes from the RHEV documentation?
> 
> There is some discrepancy between what RHEV decided to allow for guest
> networks and what actually works. The knowledgebase solution I wrote
> (https://access.redhat.com/solutions/67546) lists 0 and 3 as working, a view
> which former bonding maintainer vfalico supported (Bug 1097312).

This discrepancy should be fixed on RHEV side. IICR vfalico and jpirko asked to block modes 0 5 6 when bridges are connected when discussion multiple customer tickets due their usage.

If mode 0 can actually be enabled (with caveats) by the platform, I suppose RHEV should enable it as well.

Karen, is this the current wisdom? mode 0 is good for us?
Comment 6 Karen Noel 2015-11-17 06:15:38 EST
Amnon's networking team will be able to answer. Thanks.
Comment 7 Vlad Yasevich 2015-11-19 11:19:52 EST
WRT to bond mode 0:

Bonding mode-0 requires manual configuration on the switch that all bond members
are connected to.  The switch configuration requires all ports to be added to a single LAG (or EtherChannel) because the bond will use the same source mac on
each bond member, and without LAG on the switch, the flow will bounce between multiple ports causing unreachability.

This requirement for manual switch configuration is the reason that we do not recommend bond mode 0 being used.

-vlad
Comment 9 Vlad Yasevich 2015-11-24 13:32:17 EST
The changes wrt to bonding modes look fine to me.
Comment 11 Laura Novich 2015-12-20 03:40:12 EST
Published on December 17 version 2-24
Comment 12 Laura Novich 2015-12-20 03:43:06 EST
Published on December 17 version 2-24

Note You need to log in before you can comment on or make changes to this bug.