Bug 1264031 - [RFE] backport --noplugins option
[RFE] backport --noplugins option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpm (Show other bugs)
7.2
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Florian Festi
Karel Srot
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 07:09 EDT by Karel Srot
Modified: 2016-11-04 00:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: rpm-4.11.3-21.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:37:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Srot 2015-09-17 07:09:29 EDT
Description of problem:

As we have backported the systemd-inhibit plugin (bug 1160401) it would be useful also to backport --noplugins option.

Moreover, following change should be then made in the test suite.

diff tests-rhel/atlocal.in tests/atlocal.in 
33c33
<      MAGIC="/magic/magic" FAKECHROOT_BASE="${RPMTEST}" fakechroot "$@" --define "_topdir /build"
---
>      MAGIC="/magic/magic" FAKECHROOT_BASE="${RPMTEST}" fakechroot "$@" --define "_topdir /build" --noplugins


See also bug 1160401.
Comment 11 errata-xmlrpc 2016-11-04 00:37:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2359.html

Note You need to log in before you can comment on or make changes to this bug.