Bug 1264037 - Capsules now encapsulates the whole traffic with hosts
Capsules now encapsulates the whole traffic with hosts
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Transition Guide (Show other bugs)
6.1.1
Unspecified Unspecified
medium Severity medium (vote)
: Beta
: 6.2
Assigned To: David O'Brien
Allison Heslin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 07:31 EDT by Eric Lavarde
Modified: 2016-04-27 20:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-27 20:07:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Lavarde 2015-09-17 07:31:22 EDT
Document URL: 
https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/Transition_Guide/sect-Red_Hat_Satellite-Transition_Guide-Comparing_Satellite_5_and_Satellite_6-Satellite_Proxies_and_Capsules.html#sect-Red_Hat_Satellite-Transition_Guide-Satellite_6_Capsules

Section Number and Name: 
2.2.2. Satellite 6 Capsules

Describe the issue: 
Document states:
"In Satellite 6.0, Capsule servers do not proxy all data. Consequently, managed systems need connectivity up to Satellite 6, or an HTTP Proxy in place to provide a network bridge if required."
This is not true any more since 6.1.x

Suggestions for improvement: 
Remove the sentence altogether, and adapt the following one, which starts with "Further...".
Alternatively you might want to hint at the fact that the communication between Satellite and Capsule needs more port under 6.x than under 5.x.

Additional information:
Comment 1 Andrew Dahms 2016-02-08 22:16:03 EST
Assigning to David for review.
Comment 2 David O'Brien 2016-02-08 23:32:42 EST
Hi Eric

If I understand correctly, we should have something like this:

<delete>
In Satellite 6.0, Capsule servers do not proxy all data. Consequently, managed systems need connectivity up to Satellite 6, or an HTTP Proxy in place to provide a network bridge if required.
</delete>

Further, you cannot tier Capsule servers like you can with Proxy servers. This is illustrated in the following diagram.

Rewrite the above to just:

"You cannot tier Capsule Servers in Satellite 6 the way you can with Proxy Servers in Satellite 5."

To be honest I'm not sure how much value the diagram provides, beyond illustrating the lack of tier support.

Also, do we need to update the list of functionality that Capsules provide:
- Mirror content (Pulp Node). Content can be staged on a Pulp Node before it is used by a host.
- Mirror Puppet content (Puppet Master)
- Integrate with DHCP, DNS, TFTP, and IPA

thanks a lot.
Comment 3 David O'Brien 2016-02-15 20:24:42 EST
Emailed Eric to bump this along.
Comment 4 Eric Lavarde 2016-02-16 07:07:53 EST
(In reply to David O'Brien from comment #2)
Sorry, David, I didn't realise that the question was aimed at me...

There were 3 points in your comment:

- rewrite to ... => fine with me!
- interest of the diagram => well, it doesn't disturb, and looks neat, I would keep it.
- Update the list of functionality => I'm nitpicking but I would suggest following improvements:

> - Mirror _repository_ content (Pulp Node) and serve it to the hosts.
(not all customers might understand what a Pulp node is)
> - Mirror Puppet content and act as Puppet Master and CA
> - Integrate with DHCP, DNS, TFTP, and Kerberos realms (IPA / IdM)
(DHCP, DNS and TFTP are protocols, whereas IPA is a project; IdM is the product name and is used by the user guide instead of IPA)

I'm neither a native speaker nor a technical writer, feel free to take my comments as what they are: suggestions!

Thanks and sorry again for the delay in responding, Eric
Comment 8 Andrew Dahms 2016-04-27 20:07:59 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.