Bug 1264040 - [RFE] Send Test Mail
Summary: [RFE] Send Test Mail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Email
Version: 6.1.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Stephen Benjamin
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1122832 260381 1295277
TreeView+ depends on / blocked
 
Reported: 2015-09-17 11:34 UTC by Peter Vreman
Modified: 2020-02-14 17:33 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:56:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Peter Vreman 2015-09-17 11:34:33 UTC
Description of problem:
To test the mail configuration an option to send a Test mail would be helpful


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. When enabling Errata Notifications for a User have a process to send a test mail
2.
3.

Actual results:
No Button to send a Test mail available

Expected results:
When enabling Errata Notifications for a User have a Button to send a test mail

Additional info:

Comment 1 Bryan Kearney 2015-10-08 17:07:36 UTC
Created redmine issue http://projects.theforeman.org/issues/12113 from this bug

Comment 2 Bryan Kearney 2015-10-09 11:43:32 UTC
Connecting redmine issue http://projects.theforeman.org/issues/10649 from this bug

Comment 3 Bryan Kearney 2015-11-13 17:01:50 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/10649 has been closed
-------------
Amir Fefer
Applied in changeset commit:d7e11a8535a128ec5d7a71f55673f2049b69c3c4.

Comment 4 Bryan Kearney 2015-11-20 16:37:48 UTC
Moving this to 6.2 since it will be in the next rebase.

Comment 8 Stephen Benjamin 2016-03-24 16:15:21 UTC
Verified:

Navigation to My Account, E-mail Settings
Click "Test Mail"

Tested with correct and bogus smtp settings. With correct settings, message is delivered.  Bogus SMTP settings correctly render an error message in the UI.

Comment 11 errata-xmlrpc 2016-07-27 08:56:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.