Bug 1264041 - 'Required' and 'Attach'checkboxes for specific cluster not working
'Required' and 'Attach'checkboxes for specific cluster not working
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Linux
high Severity high
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Alexander Wels
Michael Burman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 07:36 EDT by Michael Burman
Modified: 2016-04-19 21:38 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:38:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46385 master MERGED webadmin: column checkboxes Never
oVirt gerrit 46472 None MERGED webadmin: column checkboxes Never

  None (edit)
Description Michael Burman 2015-09-17 07:36:29 EDT
Description of problem:
'Required' and 'Attach' checkboxes for specific cluster not working.
In all relevant dialogs -->
New Logical Network > Cluster >  
Clusters > Logical Networks > 'Manage Networks'
Networks > Clusters > 'Manage Networks' 
In all of this dialog windows 'Attach' and 'Required' checkboxes are not changing anything.

Version-Release number of selected component (if applicable):

How reproducible:
100

Steps to Reproduce:
1. 2 Clusters 
2. Create new network and under Cluster sub tab uncheck 'Required/'Attached' checkbox for one of the clusters and approve operation

Actual results:
Network created as required/attached for both clusters. Network status is DOWN
This behavior is for Clusters > Logical Networks > 'Manage Networks'
and Networks > Clusters > 'Manage Networks' as well.

Expected results:
Should work as expected.
Comment 1 Einav Cohen 2015-09-18 08:25:21 EDT
Alexander: related to / duplicate of bug 1257168 (please see "all relevant dialogs" in the BZ description)?
Comment 2 Alexander Wels 2015-09-18 08:30:31 EDT
bug 1257168 is about the required all/attach all header check boxes not checking/unchecking all the check boxes in the row. This is about changing the check boxes not affecting the backing model. Now it is highly possible the fix for 1257168 will in fact fix this as well. The problem was that the change event of the check box was not being handled by the code at all anymore, which maybe be the reason this is happening, but I don't want to say right now without doing some more investigating that they are the same.
Comment 3 Einav Cohen 2015-09-18 08:33:55 EDT
(In reply to Alexander Wels from comment #2)
> bug 1257168 is about the required all/attach all header check boxes not
> checking/unchecking all the check boxes in the row. This is about changing
> the check boxes not affecting the backing model. Now it is highly possible
> the fix for 1257168 will in fact fix this as well. The problem was that the
> change event of the check box was not being handled by the code at all
> anymore, which maybe be the reason this is happening, but I don't want to
> say right now without doing some more investigating that they are the same.

Thanks.
As these are not duplicates, but are most likely somewhat related, I am assigning this BZ to you.
Comment 4 Alexander Wels 2015-09-18 13:15:26 EDT
I just double checked, and the solution for 1257168 does not solve the problem with this bugzilla, so they are definitely separate issues. I will investigate more and fix it.
Comment 5 Michael Burman 2015-10-06 04:50:49 EDT
Verified on - 3.6.0-0.18.el6

Note You need to log in before you can comment on or make changes to this bug.