Bug 1264046 - Installation from a network respository aborts because of DNS error
Installation from a network respository aborts because of DNS error
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
22
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 07:51 EDT by Alex Bolenok
Modified: 2015-09-17 10:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-17 10:21:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
download error.png (176.92 KB, image/png)
2015-09-17 10:21 EDT, David Shea
no flags Details

  None (edit)
Description Alex Bolenok 2015-09-17 07:51:20 EDT
Description of problem:

Installation of Fedora 22 from a network repository aborts if DNS error occurs

How reproducible:

Always

Steps to Reproduce:

1. Run a fresh Fedora 22 installation on a computer connected to a router, serving as a DNS server.
2. Select "Install from closest mirror", wait for the metadata to complete fetching.
3. Disable the DNS service on the router
4. Select "Run installation"

Actual results:

Installation aborts saying "DNS error occured: can't resolve <mirror url>", with no way to resume.

Expected results:

Installation retries DNS queries on background, with an option to resume installation after several failed attempts.

Additional info:

DNS errors and other temporary network conditions should not be considered critical errors when installing from network. They should be retried on background. Attended installation should provide option to resume.
Comment 1 David Shea 2015-09-17 09:39:59 EDT
dnf will retry on network failures, and will try switching mirrors if a particular mirror fails, but it isn't going to retry forever.

Did anaconda crash (an unknown error has occurred) or display a dialog? If it was a crash, please attach the logs from /tmp as individual, text/plain attachments.
Comment 2 Alex Bolenok 2015-09-17 09:58:10 EDT
It displayed a dialog, saying something along the lines of "DNS error occured: can't resolve <mirror url>. A critical error happened during installation. The installation cannot continue".

The only option was to reset the machine (the dialog had no buttons and did not respond to Ctrl-Alt-Del).

Can't look it up because I installed Fedora on the second attempt (which formatted the drives and destroyed logs from the first attempt), but can try to reproduce it on a virtual box, if needed.

My understanding is that in case of a network error the user should be brought back to the options screen and given an option to fix the network settings.
Comment 3 David Shea 2015-09-17 10:21:38 EDT
Created attachment 1074469 [details]
download error.png

As I said, anaconda and the libraries it uses for packaging will retry in case of a network error, but will not retry forever. Once you have started the installation, many of the items that are configurable on the summary screen--storage, package sets--have been or are being written to the system, putting attempts to reconfigure in an inconsistent state, so to retry you might as well start the installer again. Which is exactly the choice that we offer.

(In reply to Alex Bolenok from comment #2)
> The only option was to reset the machine (the dialog had no buttons and did
> not respond to Ctrl-Alt-Del).

The "Exit Installer" button on the dialog will exit the installer.

Note You need to log in before you can comment on or make changes to this bug.