Bug 1264054 - gnome-terminal: background color change may break applications
gnome-terminal: background color change may break applications
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-terminal (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Debarshi Ray
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 08:06 EDT by Florian Weimer
Modified: 2015-11-19 04:02 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 04:02:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Weimer 2015-09-17 08:06:45 EDT
The GNOME rebase in Red Hat Enterprise Linux 7.2 changes the default color scheme from black-on-white to white-on-dark-grey.  Previous versions (back to Red Hat Enterprise Linux 5 at least) used the black-on-white scheme, which means that customers will be accustomed to it, and legacy terminal applications will use colors which match it.  The new color scheme could well make such applications unusable.
Comment 1 Debarshi Ray 2015-09-17 13:40:05 EDT
Yes, I agree. This is something best done in RHEL 8, in my opinion, not in a RHEL 7 point release.
Comment 2 Matthias Clasen 2015-09-18 11:48:28 EDT
I think we should fix this for 7.2
Comment 8 Michael Boisvert 2015-10-01 09:50:58 EDT
100% Correct, the lesson here is not to trust an older monitor. gnome-terminal-3.14.3-2 does indeed have a white background.

Switching to verified.
Comment 11 errata-xmlrpc 2015-11-19 04:02:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2243.html

Note You need to log in before you can comment on or make changes to this bug.