Bug 1264056 - Display artefacts on nvidia
Display artefacts on nvidia
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: clutter (Show other bugs)
7.1
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Owen Taylor
Desktop QE
: FastFix
Depends On:
Blocks: 1298243 1393395
  Show dependency treegraph
 
Reported: 2015-09-17 08:11 EDT by John Hodrien
Modified: 2017-01-10 14:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-10 14:16:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Hodrien 2015-09-17 08:11:48 EDT
Description of problem:
Rendering artefacts visible in a number of applications, including firefox, when used with nvidia drivers due to a bug in clutter.

Version-Release number of selected component (if applicable):
1.14.4-12.el7_1.1

How reproducible:
On every machine with nvidia graphics I've tested

Steps to Reproduce:
1.  Start firefox
2.  Open a complex web page
3.  Move the mouse around

Actual results:
Tearing and visual artefacts

Expected results:
Normal rendering

Additional info:

This has already been reported against Fedora, and was fixed in later versions of clutter.  Bugzilla #1081625 references the simple patch that fixes the issue.

https://git.gnome.org/browse/clutter/commit/?h=clutter-1.16&id=6665f47d66a871b6e1a5f4200282f42da043a0e8

This patch has been tested as applied the EL7 SRPM and is confirmed as working.  The fault is definitely with clutter and not with nvidia.
Comment 2 Ashish Shah 2015-10-22 05:38:55 EDT
Patch looks available in clutter-1.20.0-4.el7 under rhel7.2 beta
Comment 4 Owen Taylor 2017-01-10 14:16:58 EST
As noted in comment 2, this was resolved in RHEL-7.2.

Note You need to log in before you can comment on or make changes to this bug.