Bug 1264182 - Support details for Images on Red Hat Registry. [NEEDINFO]
Support details for Images on Red Hat Registry.
Status: CLOSED NEXTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Ashley Hardin
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 14:22 EDT by Ryan Howe
Modified: 2016-02-02 12:45 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 12:45:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
vigoyal: needinfo? (baulakh)


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2015-09-17 14:22:36 EDT
Description of problem:

We need details in our docs or on access.redhat.com that outline what images are supported by redhat and which images are tech preview and not supported on openshift 

Version-Release number of selected component (if applicable):
v3.0.1 

How reproducible:
100%


What is supported? 

[root@master ~]# docker search openshift
redhat.com   registry.access.redhat.com/aos3/aos-deployer                                     Atomic OpenShift Deployer                       0                    
redhat.com   registry.access.redhat.com/aos3/aos-docker-registry                              Atomic OpenShift Docker Registry                0                    
redhat.com   registry.access.redhat.com/aos3/aos-haproxy-router                               Atomic OpenShift Router                         0                    
redhat.com   registry.access.redhat.com/aos3/aos-keepalived-ipfailover                        Atomic OpenShift Pod High Availability Sup...   0                    
redhat.com   registry.access.redhat.com/aos3/aos-pod                                          Atomic OpenShift Pod                            0                    
redhat.com   registry.access.redhat.com/jboss-amq-6-openshift3_beta/amq-openshift             JBoss A-MQ 6.2 OpenShift                        0                    
redhat.com   registry.access.redhat.com/jboss-amq-6/amq-openshift                             JBoss A-MQ 6.2 OpenShift                        0                    
redhat.com   registry.access.redhat.com/jboss-eap-6-openshift3_beta/eap-openshift             JBoss EAP 6.4 OpenShift                         0                    
redhat.com   registry.access.redhat.com/jboss-eap-6/eap-openshift                             JBoss EAP 6.4 OpenShift                         0                    
redhat.com   registry.access.redhat.com/jboss-webserver-3-openshift3_beta/tomcat7-openshift   JBoss JWS 3.0 OpenShift                         0                    
redhat.com   registry.access.redhat.com/jboss-webserver-3-openshift3_beta/tomcat8-openshift   JBoss JWS 3.0 OpenShift                         0                    
redhat.com   registry.access.redhat.com/jboss-webserver-3/tomcat7-openshift                   JBoss JWS 3.0 OpenShift                         0                    
redhat.com   registry.access.redhat.com/jboss-webserver-3/tomcat8-openshift                   JBoss JWS 3.0 OpenShift                         0                    
redhat.com   registry.access.redhat.com/openshift3/jenkins-1-rhel7                            OpenShift Enterprise Jenkins                    0                    
redhat.com   registry.access.redhat.com/openshift3/mongodb-24-rhel7                           OpenShift Enterprise MongoDB 2.4                0                    
redhat.com   registry.access.redhat.com/openshift3/mysql-55-rhel7                             OpenShift Enterprise Mysql 5.5                  0                    
redhat.com   registry.access.redhat.com/openshift3/nodejs-010-rhel7                           OpenShift Enterprise Nodejs 0.10 Builder I...   0                    
redhat.com   registry.access.redhat.com/openshift3/ose-deployer                               OpenShift Enterprise Deployer                   0                    
redhat.com   registry.access.redhat.com/openshift3/ose-docker-builder                         OpenShift Enterprise Docker Builder             0                    
redhat.com   registry.access.redhat.com/openshift3/ose-docker-registry                        OpenShift Enterprise Docker Registry            0                    
redhat.com   registry.access.redhat.com/openshift3/ose-haproxy-router                         OpenShift Enterprise Router                     0                    
redhat.com   registry.access.redhat.com/openshift3/ose-keepalived-ipfailover                  OpenShift Enterprise Pod High Availability...   0                    
redhat.com   registry.access.redhat.com/openshift3/ose-pod                                    OpenShift Enterprise Infrastructure Pod         0                    
redhat.com   registry.access.redhat.com/openshift3/ose-sti-builder                            OpenShift Enterprise Source-To-Image Builder    0                    
redhat.com   registry.access.redhat.com/openshift3/perl-516-rhel7                             OpenShift Enterprise Perl 5.16 Builder Image    0                    
redhat.com   registry.access.redhat.com/openshift3/php-55-rhel7                               OpenShift Enterprise PHP 5.5 Builder Image      0                    
redhat.com   registry.access.redhat.com/openshift3/postgresql-92-rhel7                        OpenShift Enterprise Postgresql 9.2             0                    
redhat.com   registry.access.redhat.com/openshift3/python-33-rhel7                            OpenShift Enterprise Python 3.3 Builder Image   0                    
redhat.com   registry.access.redhat.com/openshift3/ruby-20-rhel7                              OpenShift Enterprise Ruby 2.0 Builder Image     0
Comment 2 Paul Weil 2015-09-22 11:18:06 EDT
Ben, does this fall under the image eco part of your team or more under packaging?
Comment 3 Ben Parees 2015-09-22 11:23:39 EDT
i'm guessing packaging... Brenton?
Comment 4 Brenton Leanhardt 2015-09-23 08:35:08 EDT
I'm not sure exactly why the Atomic Enterprise Beta didn't use a beta namespace like what was used for the OpenShift Enterprise Beta (/openshift3_beta/).  I could see how that is confusing.  That was probably just a mistake we'll have to live with since the beta isn't going to last much longer.

As for openshift documentation, we can ask Alex if he or someone else on the docs team could find a suitable place to clarify the images under /openshift3/.  The OpenShift docs should probably also mention the JBoss related images that have _openshift3 in the name and how they differ from the other JBoss images (I'm assuming they are just plan container images).

Is GSS getting calls about openshift users being confused by the aos3 images?  That would be surprising to me.  Nothing in the openshift docs mentions the aos3 images right now (nor should it).
Comment 12 openshift-github-bot 2016-01-29 12:03:57 EST
Commits pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/afbfec5e352ea80cc44828af885426446a3682f8
Bug 1264182, refined the image support details for OSE

https://github.com/openshift/openshift-docs/commit/cdc4ae8b48d1992cf6e1e02b29fae9237cc008a5
Merge pull request #1423 from ahardin-rh/support-details

Bug 1264182, added image support details
Comment 14 Ashley Hardin 2016-02-02 12:45:19 EST
This is now published for dedicated-3.1, openshift-3.1, and openshift-3.0:

https://docs.openshift.com/enterprise/latest/using_images/index.html

Please reopen if further work is needed. Thanks!

Note You need to log in before you can comment on or make changes to this bug.