Bug 1264185 - F23 beta - dnf history info <packagename> gives stacktrace
F23 beta - dnf history info <packagename> gives stacktrace
Status: CLOSED DUPLICATE of bug 1245121
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 14:31 EDT by Dusty Mabe
Modified: 2015-09-17 16:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-17 16:44:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dusty Mabe 2015-09-17 14:31:53 EDT
Description of problem:

I get a stacktrace when requesting history info about a named package:


[root@ip-10-43-205-82 ~]# dnf install -y fpaste
...
[root@ip-10-43-205-82 ~]# dnf history list
Last metadata expiration check performed 0:20:26 ago on Thu Sep 17 18:08:40 2015.
ID     | Command line             | Date a | Action | Altere
-------------------------------------------------------------------------------
     6 |                          | 2015-09-17 18:22 | Install        |    1   
     5 |                          | 2015-09-17 18:14 | Install        |    1   
     4 |                          | 2015-09-17 18:09 | Install        |   73   
     3 |                          | 2015-09-16 21:48 | Erase          |    7   
     2 |                          | 2015-09-16 21:48 | Erase          |   11   
     1 |                          | 2015-09-16 21:44 | Install        |  281 EE
[root@ip-10-43-205-82 ~]# dnf history info 6
Last metadata expiration check performed 0:20:39 ago on Thu Sep 17 18:08:40 2015.
Transaction ID : 6
Begin time     : Thu Sep 17 18:22:53 2015
Begin rpmdb    : 337:d634a8515b86927d96dd04a0433a4ebd50cd8528
End time       :            18:22:54 2015 (1 seconds)
End rpmdb      : 338:bb9787b129cda1cc45786e3128d2cc1c2f045b15
User           : Fedora Cloud User <fedora>
Return-Code    : Success
Transaction performed with:
    Installed     dnf-1.1.0-2.fc23.noarch        @koji-override-0
    Installed     rpm-4.13.0-0.rc1.3.fc23.x86_64 @koji-override-0
Packages Altered:
    Install fpaste-0.3.8.0-1.fc23.noarch @fedora
[root@ip-10-43-205-82 ~]# 
[root@ip-10-43-205-82 ~]# dnf history info fpaste
Last metadata expiration check performed 0:20:45 ago on Thu Sep 17 18:08:40 2015.
Transaction ID : 6
Begin time     : Thu Sep 17 18:22:53 2015
Begin rpmdb    : 337:d634a8515b86927d96dd04a0433a4ebd50cd8528
End time       :            18:22:54 2015 (1 seconds)
End rpmdb      : 338:bb9787b129cda1cc45786e3128d2cc1c2f045b15
User           : Fedora Cloud User <fedora>
Return-Code    : Success
Transaction performed with:
    Installed     dnf-1.1.0-2.fc23.noarch        @koji-override-0
    Installed     rpm-4.13.0-0.rc1.3.fc23.x86_64 @koji-override-0
Packages Altered:
Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 193, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 139, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1083, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/__init__.py", line 1217, in run
    ret = self.output.historyInfoCmd(extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1535, in historyInfoCmd
    self._historyInfoCmd(tid, pats)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1673, in _historyInfoCmd
    self.historyInfoCmdPkgsAltered(old, pats)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1748, in historyInfoCmdPkgsAltered
    x, m, u = dnf.yum.packages.parsePackages([hpkg], pats)
  File "/usr/lib/python3.4/site-packages/dnf/yum/packages.py", line 76, in parsePackages
    exactmatch.update(pkgdict[command])
TypeError: unhashable type: 'YumHistoryPackageState'


Version-Release number of selected component (if applicable):
dnf-1.1.0-2.fc23.noarch

How reproducible:
Always

Steps to Reproduce:
See description.

Additional info:
Test was run on ec2 cloud image ami-e96d1b8c
Comment 1 Radek Holy 2015-09-17 16:44:24 EDT

*** This bug has been marked as a duplicate of bug 1245121 ***

Note You need to log in before you can comment on or make changes to this bug.