Bug 126420 - [RHEL3] control-center mouse properties capplet only applies left-handed configuration for primary mouse
Summary: [RHEL3] control-center mouse properties capplet only applies left-handed conf...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: control-center   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: Desktop
Depends On:
Blocks: RHEL3U8CanFix
TreeView+ depends on / blocked
 
Reported: 2004-06-21 14:08 UTC by Brian Long
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: RHBA-2006-0327
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 14:37:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0327 normal SHIPPED_LIVE control-center bug fix update 2006-07-19 18:42:00 UTC

Description Brian Long 2004-06-21 14:08:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040202

Description of problem:
When I configure RHEL 3 with two mice in XF86Config and configure
Gnome to enable left-handed mouse, only the primary "CorePointer"
mouse is configured.  The secondary "AlwaysCore" mouse is still
right-handed.

X windows, GNOME and KDE need to offer a manner to set each mouse
individually left- or right-handed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure two mice in XF86Config
2. Change GNOME mouse setting to Left-Handed.

    

Actual Results:  Only primary mouse "CorePointer" is changed to
left-handed.

Expected Results:  Both mice "CorePointer" and "AlwaysCore" should be
left-handed at the very least.  Ideally, each mouse would be
separately configured for left- or right-handed.

Additional info:

RHEL 3 U2.

Comment 1 Havoc Pennington 2004-06-21 15:33:16 UTC
Thanks, it would be helpful for us to understand the usage scenario
for configuring the mice separately; is this for two people using one
workstation?

Comment 2 Brian Long 2004-06-21 15:51:10 UTC
The usage scenario is that a PS/2 mouse is configured during
kickstart.   Our XF86Config file also contains the USB mouse entry.

My system only has the USB mouse currently, but since it's configured
as secondary (AlwaysCore) instead of primary (CorePointer), it's not
being changed to left-handed.

Only if I comment out the PS/2 mouse will the USB mouse become
left-handed.  I'd like to be able to plug in a PS/2 mouse in the
future (and possibly remove the USB mouse) without messing with
XF86Config.

We have PS/2 and USB mouse configured at the same time to avoid
changing the config file as users plug and unplug USB mice.

Comment 3 Brian Long 2004-06-21 15:57:17 UTC
I believe the following Fedora bugs might be related:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=123800
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=124344

Comment 4 Brian Long 2004-07-06 19:09:43 UTC
Is it a bug or a feature that XFree86 only supports left-handed mice
as CorePointer and not AlwaysCore?  I would like for my PS/2 mouse and
USB mouse to be left-handed at the same time.  This is currently not
possible.  I believe this is a bug in RHEL (and all previous Red Hat
releases) and I'd like to see it fixed.  If RHEL is an enterprise
workstation and server release, I believe it needs to be fixed, not
neglected.  Shall I open a support case and escalate this?

Comment 16 Ray Strode [halfline] 2006-03-24 19:16:29 UTC
adding dev ack back because devel work is done.

Comment 21 Red Hat Bugzilla 2006-07-20 14:37:07 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0327.html



Note You need to log in before you can comment on or make changes to this bug.