This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1264205 - [abrt] xfce-polkit: g_type_check_instance_is_fundamentally_a(): xfce-polkit killed by SIGSEGV
[abrt] xfce-polkit: g_type_check_instance_is_fundamentally_a(): xfce-polkit k...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfce-polkit (Show other bugs)
23
x86_64 Unspecified
high Severity high
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:705945195f99da21797b343284e...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 17:07 EDT by Raphael Groner
Modified: 2015-10-04 15:15 EDT (History)
1 user (show)

See Also:
Fixed In Version: xfce-polkit-0.1-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 15:15:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphael Groner 2015-09-17 17:07:20 EDT
Description of problem:
crashed after click on gparted menu entry

Version-Release number of selected component:
xfce-polkit-0-0.1.20130717gitbe888ee.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/libexec/xfce-polkit
crash_function: g_type_check_instance_is_fundamentally_a
executable:     /usr/libexec/xfce-polkit
global_pid:     1411
kernel:         4.2.0-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (8 frames)
 #0 g_type_check_instance_is_fundamentally_a at gtype.c:4028
 #2 g_task_finalize at gtask.c:627
 #4 auth_dlg_data_free at xfce-polkit-listener.c:31
 #5 g_cclosure_marshal_VOID__ENUMv at gmarshal.c:1496
 #6 _g_closure_invoke_va at gclosure.c:864
 #8 g_signal_emit_by_name at gsignal.c:3468
 #9 io_watch_have_data at polkitagentsession.c:498
 #14 gtk_main at gtkmain.c:1268
Comment 1 Raphael Groner 2015-09-17 17:30:50 EDT
Another user experienced a similar problem:

crashed after click on gparted menu entry

reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/libexec/xfce-polkit
crash_function: g_type_check_instance_is_fundamentally_a
executable:     /usr/libexec/xfce-polkit
global_pid:     1411
kernel:         4.2.0-300.fc23.x86_64
package:        xfce-polkit-0-0.1.20130717gitbe888ee.fc23
reason:         xfce-polkit killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 2 Raphael Groner 2015-09-19 05:49:20 EDT
Another user experienced a similar problem:

run GParted from application menu

reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/libexec/xfce-polkit
crash_function: g_type_check_instance_is_fundamentally_a
executable:     /usr/libexec/xfce-polkit
global_pid:     1689
kernel:         4.2.0-300.fc23.x86_64
package:        xfce-polkit-0-0.1.20130717gitbe888ee.fc23
reason:         xfce-polkit killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 3 Raphael Groner 2015-09-19 05:50:10 EDT
This crash is not reproducible with F22.
Comment 4 Raphael Groner 2015-09-19 06:43:24 EDT

*** This bug has been marked as a duplicate of bug 1264590 ***
Comment 5 Fedora Update System 2015-09-26 11:16:40 EDT
xfce-polkit-0.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b1eba48e8e
Comment 6 Fedora Update System 2015-09-26 20:54:18 EDT
xfce-polkit-0.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update xfce-polkit'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b1eba48e8e
Comment 7 Fedora Update System 2015-10-04 15:15:15 EDT
xfce-polkit-0.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.