Bug 1264220 - ss -z falsely shows selinux is not enabled
ss -z falsely shows selinux is not enabled
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iproute (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Phil Sutter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 18:32 EDT by Striker Leggette
Modified: 2015-10-03 17:13 EDT (History)
3 users (show)

See Also:
Fixed In Version: iproute-3.16.0-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-03 17:13:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Striker Leggette 2015-09-17 18:32:18 EDT
Description of problem:
 - '/usr/sbin/ss -z' falsely reports selinux being disabled

Version-Release number of selected component (if applicable):
iproute-3.16.0-3.fc22.x86_64

How reproducible:
Always

Steps to Reproduce:
1. /usr/sbin/ss -z
2.
3.

Actual results:
ss: SELinux is not enabled.

Expected results:
ss: SELinux is enabled.

Additional info:
Comment 1 Striker Leggette 2015-09-17 18:33:37 EDT
striker ~ $ /usr/sbin/ss -z
ss: SELinux is not enabled.

striker ~ $ getenforce
Enforcing
Comment 2 Striker Leggette 2015-09-17 18:50:59 EDT
Possibly due to unfinished code?



static int is_selinux_enabled(void)
{
        return -1;
}
 
############
 
                case 'Z':
                        if (is_selinux_enabled() <= 0) {
                                fprintf(stderr, "ss: SELinux is not enabled.\n");
                                exit(1);
                        }
Comment 3 Fedora Admin XMLRPC Client 2015-09-24 04:03:16 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Update System 2015-09-24 11:39:54 EDT
iproute-3.16.0-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16619
Comment 5 Fedora Update System 2015-09-26 20:38:48 EDT
iproute-3.16.0-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update iproute'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16619
Comment 6 Striker Leggette 2015-09-27 10:43:44 EDT
confirmed issue resolved
Comment 7 Fedora Update System 2015-10-03 17:13:55 EDT
iproute-3.16.0-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.