Bug 1264231 - rubygem-ethon-0.9.0 is available
rubygem-ethon-0.9.0 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-ethon (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jun Aruga
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 20:13 EDT by Upstream Release Monitoring
Modified: 2016-05-27 23:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: rubygem-ethon-0.9.0-1.fc25 rubygem-ethon-0.9.0-1.fc24
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-27 23:34:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[patch] Update to 0.8.1 (#1264231) (907 bytes, patch)
2016-01-10 19:12 EST, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (14.89 KB, patch)
2016-04-28 08:12 EDT, Upstream Release Monitoring
no flags Details | Diff
Update to Ethon 0.9.0 (1.56 KB, patch)
2016-05-19 05:25 EDT, Jun Aruga
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2015-09-17 20:13:02 EDT
Latest upstream release: 0.8.0
Current version/release in rawhide: 0.7.4-1.fc23
URL: http://rubygems.org/gems/ethon

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2015-09-17 20:13:08 EDT
Failed to kick off scratch build.

cmd:  sha256sum /var/tmp/thn-Ndbvnk/100.0%
return code:  1
stdout:

stderr:
sha256sum: /var/tmp/thn-Ndbvnk/100.0%: No such file or directory
Comment 2 Upstream Release Monitoring 2016-01-10 19:12:51 EST
Latest upstream release: 0.8.1
Current version/release in rawhide: 0.7.4-1.fc23
URL: http://rubygems.org/gems/ethon

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 3 Upstream Release Monitoring 2016-01-10 19:12:58 EST
Created attachment 1113421 [details]
[patch] Update to 0.8.1 (#1264231)
Comment 4 Upstream Release Monitoring 2016-01-10 19:15:33 EST
Scratch build completed http://koji.fedoraproject.org/koji/taskinfo?taskID=12493699
Comment 5 Upstream Release Monitoring 2016-04-28 08:12:11 EDT
Latest upstream release: 0.9.0
Current version/release in rawhide: 0.7.4-2.fc24
URL: http://rubygems.org/gems/ethon

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/4422/
Comment 6 Upstream Release Monitoring 2016-04-28 08:12:21 EDT
Patching or scratch build for rubygem-ethon-0.7.4 failed.
Comment 7 Upstream Release Monitoring 2016-04-28 08:12:23 EDT
Created attachment 1151836 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 8 Upstream Release Monitoring 2016-04-28 08:12:24 EDT
Patches were not touched. All were applied properly
Comment 9 Jun Aruga 2016-05-19 05:19:34 EDT
Let me do it!
Comment 10 Jun Aruga 2016-05-19 05:25 EDT
Created attachment 1159328 [details]
Update to Ethon 0.9.0

I updated to version 0.9.0.

# High light

- I changed required version for rspec from "< 3" to latest version. Because the latest version is used on upstream of Ethon.

# Detail for my checking.

## dependency: ok

+ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem(ethon)'
rubygem-typhoeus-0:0.7.2-1.fc23.noarch

+ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem-ethon'
rubygem-ethon-doc-0:0.7.4-1.fc23.noarch
rubygem-ethon-doc-0:0.7.4-2.fc24.noarch

+ dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem(ethon)'
rubygem-typhoeus-0:0.7.2-1.fc23.src

+ dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem-ethon'
  => no result.

## install package & run it on irb: ok

## rpmlint: ok.

## license check: ok.

Could you check my patch?
Thanks.
Comment 11 Vít Ondruch 2016-05-19 05:30:39 EDT
LGTM. I added you committer rights in PkgDB. Feel free to push these changes.
Comment 12 Upstream Release Monitoring 2016-05-19 06:34:46 EDT
jaruga's rubygem-ethon-0.9.0-1.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=767020
Comment 13 Fedora Update System 2016-05-19 07:10:05 EDT
rubygem-ethon-0.9.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f148a294f9
Comment 14 Jun Aruga 2016-05-19 07:11:19 EDT
Hi, Vit.
Thanks for the review!
Comment 15 Fedora Update System 2016-05-23 03:58:27 EDT
rubygem-ethon-0.9.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f148a294f9
Comment 16 Fedora Update System 2016-05-23 22:57:58 EDT
rubygem-ethon-0.9.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f148a294f9
Comment 17 Fedora Update System 2016-05-27 23:34:41 EDT
rubygem-ethon-0.9.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.