Bug 1264241 - guestfish "run" command fails to mount volume.
guestfish "run" command fails to mount volume.
Status: CLOSED DUPLICATE of bug 1239154
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 20:57 EDT by Pedro Sigwald
Modified: 2015-09-18 03:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-18 03:43:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Sigwald 2015-09-17 20:57:47 EDT
Description of problem:
guestfish -a <path_to_volume> 
><fs> run
libguestfs: error: /usr/bin/supermin5 exited with error status 1.
To see full error messages you may need to enable debugging.
See http://libguestfs.org/guestfs-faq.1.html#debugging-libguestfs

Version-Release number of selected component (if applicable): 5.1.10

This is the output of libguestfs-test-tool

     ************************************************************
     *                    IMPORTANT NOTICE
     *
     * When reporting bugs, include the COMPLETE, UNEDITED
     * output below in your bug report.
     *
     ************************************************************
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin
SELinux: Permissive
guestfs_get_append: (null)
guestfs_get_autosync: 1
guestfs_get_backend: libvirt
guestfs_get_backend_settings: []
guestfs_get_cachedir: /var/tmp
guestfs_get_direct: 0
guestfs_get_hv: /usr/libexec/qemu-kvm
guestfs_get_memsize: 500
guestfs_get_network: 0
guestfs_get_path: /usr/lib64/guestfs
guestfs_get_pgroup: 0
guestfs_get_program: libguestfs-test-tool
guestfs_get_recovery_proc: 1
guestfs_get_selinux: 0
guestfs_get_smp: 1
guestfs_get_tmpdir: /tmp
guestfs_get_trace: 0
guestfs_get_verbose: 1
host_cpu: x86_64
Launching appliance, timeout set to 600 seconds.
libguestfs: launch: program=libguestfs-test-tool
libguestfs: launch: version=1.28.1rhel=7,release=1.18.el7,libvirt
libguestfs: launch: backend registered: unix
libguestfs: launch: backend registered: uml
libguestfs: launch: backend registered: libvirt
libguestfs: launch: backend registered: direct
libguestfs: launch: backend=libvirt
libguestfs: launch: tmpdir=/tmp/libguestfsBvng3w
libguestfs: launch: umask=0022
libguestfs: launch: euid=0
libguestfs: libvirt version = 1002008 (1.2.8)
libguestfs: guest random name = guestfs-ms5nvkinvp3kd1om
libguestfs: [00000ms] connect to libvirt
libguestfs: opening libvirt handle: URI = qemu:///system, auth = default+wrapper, flags = 0
libguestfs: successfully opened libvirt handle: conn = 0x7f4465e66aa0
libguestfs: qemu version (reported by libvirt) = 2001002 (2.1.2)
libguestfs: [00005ms] get libvirt capabilities
libguestfs: [00011ms] parsing capabilities XML
libguestfs: [00011ms] build appliance
libguestfs: [00011ms] begin building supermin appliance
libguestfs: [00011ms] run supermin
libguestfs: command: run: /usr/bin/supermin5
libguestfs: command: run: \ --build
libguestfs: command: run: \ --verbose
libguestfs: command: run: \ --if-newer
libguestfs: command: run: \ --lock /var/tmp/.guestfs-0/lock
libguestfs: command: run: \ --copy-kernel
libguestfs: command: run: \ -f ext2
libguestfs: command: run: \ --host-cpu x86_64
libguestfs: command: run: \ /usr/lib64/guestfs/supermin.d
libguestfs: command: run: \ -o /var/tmp/.guestfs-0/appliance.d
supermin: version: 5.1.10
supermin: rpm: detected RPM version 4.11
supermin: package handler: fedora/rpm
supermin: acquiring lock on /var/tmp/.guestfs-0/lock
supermin: build: /usr/lib64/guestfs/supermin.d
supermin: build: visiting /usr/lib64/guestfs/supermin.d/base.tar.gz type gzip base image (tar)
supermin: build: visiting /usr/lib64/guestfs/supermin.d/daemon.tar.gz type gzip base image (tar)
supermin: build: visiting /usr/lib64/guestfs/supermin.d/excludefiles type uncompressed excludefiles
supermin: build: visiting /usr/lib64/guestfs/supermin.d/hostfiles type uncompressed hostfiles
supermin: build: visiting /usr/lib64/guestfs/supermin.d/init.tar.gz type gzip base image (tar)
supermin: build: visiting /usr/lib64/guestfs/supermin.d/packages type uncompressed packages
supermin: build: visiting /usr/lib64/guestfs/supermin.d/udev-rules.tar.gz type gzip base image (tar)
supermin: build: 185 packages, including dependencies
supermin: build: 30483 files
supermin: build: 17300 files, after removing unreadable files
supermin: build: 8700 files, after matching excludefiles
supermin: build: 8704 files, after adding hostfiles
supermin: build: 8733 files, after munging
supermin: kernel: picked kernel vmlinuz-3.10.0-229.11.1.el7.x86_64
supermin: kernel: picked modules path /lib/modules/3.10.0-229.11.1.el7.x86_64
supermin: kernel: kernel_version 3.10.0-229.11.1.el7.x86_64
supermin: kernel: modules /lib/modules/3.10.0-229.11.1.el7.x86_64
supermin: ext2: creating empty ext2 filesystem '/var/tmp/.guestfs-0/appliance.d.7p0f1q3r/root'
supermin: ext2: populating from base image
supermin: ext2: copying files from host filesystem
supermin: ext2fs_file_write: /var/log/tallylog: Could not allocate block in ext2 filesystem
supermin: failure: ext2fs_file_write
libguestfs: error: /usr/bin/supermin5 exited with error status 1, see debug messages above
libguestfs-test-tool: failed to launch appliance
libguestfs: closing guestfs handle 0x7f4465e66400 (state 0)
libguestfs: command: run: rm
libguestfs: command: run: \ -rf /tmp/libguestfsBvng3w
Comment 1 Richard W.M. Jones 2015-09-18 03:43:04 EDT
This is fixed by upstream commit
https://github.com/libguestfs/libguestfs/commit/95bb1916eb1b2f6f9e9575cf4bf92501292bf545

Unfortunately I didn't manage to get this fix into RHEL 7.2,
but it will be included in RHEL 7.3.  Nevertheless as a workaround
you can do:

echo -/var/log/tallylog > /usr/lib64/guestfs/supermin.d/bz1264241

*** This bug has been marked as a duplicate of bug 1239154 ***
Comment 2 Richard W.M. Jones 2015-09-18 03:45:54 EDT
Probably better workaround:

echo -/var/log/tallylog > /usr/lib64/guestfs/supermin.d/zz-log

Note You need to log in before you can comment on or make changes to this bug.