Bug 1264281 - RHEV-M shouldn't allow to select Red Hat Storage node as SPM
RHEV-M shouldn't allow to select Red Hat Storage node as SPM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.4.5
All Linux
high Severity high
: ovirt-4.0.2
: ---
Assigned To: Ramesh N
SATHEESARAN
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 01:58 EDT by Pawan kumar Vilayatkar
Modified: 2016-08-23 16:29 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This update disables the 'Select as SPM' option in the Manager for Red Hat Gluster Storage (RHGS) nodes because selecting a RHGS host as SPM is meaningless since it doesn't provide a virtualization service.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 16:29:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Select-as-SPM-RHEVM (56.21 KB, image/png)
2015-09-18 02:05 EDT, Pawan kumar Vilayatkar
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 59474 master MERGED engine: Enable 'Select as SPM' only for Virt Cluster 2016-06-22 07:27 EDT
oVirt gerrit 59616 ovirt-engine-4.0 MERGED engine: Enable 'Select as SPM' only for Virt Cluster 2016-06-24 07:55 EDT

  None (edit)
Description Pawan kumar Vilayatkar 2015-09-18 01:58:07 EDT
Hello 

- What is the nature and description of the request? 

Disable 'Select as SPM' option for RHGS (Red Hat Gluster storage) nodes in RHEV-M console


- Why do you need this? (List the business requirements here)

RHGS nodes cannot act as SPM by design, they are providing storage, no virtual machines are running on them


- How would you like to achieve this? (List the functional requirements here)

Remove (or disable) 'Select as SPM' option for RHGS nodes in RHEV-M console



- Do you have any specific time-line dependencies?

No. But this is a bug and should be fixed as soon as possible



- List any affected packages or components.

rhevm


- Would you be able to assist in testing this functionality if implemented?

Yes


- For each functional requirement listed in the previous question, can test to confirm the requirement is successfully implemented.

Yes
Comment 1 Pawan kumar Vilayatkar 2015-09-18 02:05:09 EDT
Created attachment 1074688 [details]
Select-as-SPM-RHEVM
Comment 2 Allon Mureinik 2015-09-20 09:15:29 EDT
This sounds more like a bugfix than an RFE.

An RHGS node obviously can't be an SPM, and this should be blocked from both the GUI and REST.
Comment 3 Sandro Bonazzola 2015-10-26 08:28:31 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 4 Yaniv Kaul 2016-06-02 05:49:24 EDT
Is anyone looking at this bug/RFE?
Comment 5 Ramesh N 2016-06-20 07:05:32 EDT
'Select as SPM' action should be supported only for Virt Nodes. I Will add a validation to UI and Backend to make sure it is enabled only if the Node has Virt service enabled.
Comment 6 SATHEESARAN 2016-08-22 08:03:52 EDT
Tested with RHGS 3.1.3 ( vdsm-4.17.33-1.el7rhgs ) and RHV 4.0.2-7

While selecting the RHGS nodes, the option 'Select as SPM' is not highlighted

Note :
But while adding the new host, the new host deploy window shows up the policies related to virt node and also the SPM tab. The bug[1] has been filed for the same

[1] - https://bugzilla.redhat.com/show_bug.cgi?id=1368457
Comment 8 errata-xmlrpc 2016-08-23 16:29:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html

Note You need to log in before you can comment on or make changes to this bug.