Bug 1264362 - (CVE-2015-6500) CVE-2015-6500 owncloud: Information Exposure Through Directory Listing in the file scanner
CVE-2015-6500 owncloud: Information Exposure Through Directory Listing in the...
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Product Security
impact=low,public=20150824,reported=2...
: Security
Depends On: 1264365 1264366 1264367
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 06:00 EDT by Adam Mariš
Modified: 2017-01-03 03:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-03 03:29:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Mariš 2015-09-18 06:00:44 EDT
Due to an incorrect usage of an ownCloud internal file system function the passed path to the file scanner was resolved relatively. An authenticated adversary may thus be able to get a listing of directories (but not the containing files) existing on the filesystem. However, it is not possible to access any of these files.

Affected versions are < 8.1.1 for 8.1.x and < 8.0.6 for 8.0.x

External reference:

https://owncloud.org/security/advisory/?id=oc-sa-2015-014
Comment 1 Adam Williamson 2015-09-18 06:05:35 EDT
8.0.7 has been sitting in u-t without karma for two weeks, I'll push it.
Comment 2 Adam Mariš 2015-09-18 06:07:29 EDT
Created owncloud tracking bugs for this issue:

Affects: fedora-all [bug 1264365]
Affects: epel-6 [bug 1264366]
Affects: epel-7 [bug 1264367]
Comment 3 Adam Williamson 2015-09-18 06:09:52 EDT
sigh, and so my bugzilla mailbox explodes...I've submitted 8.0.7 to stable for all affected releases except EL6, it's not clear from the advisory if 7.x is actually susceptible to this, but we can't just bump EL6 to 8.x.
Comment 4 Shawn Iwinski 2016-12-28 17:07:31 EST
All dependent bugs closed.
Comment 5 Adam Mariš 2017-01-03 03:29:27 EST
(In reply to Shawn Iwinski from comment #4)
> All dependent bugs closed.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.