Bug 1264390 - storaged path has changed --> runs as unconfined_service_t
storaged path has changed --> runs as unconfined_service_t
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 06:45 EDT by Milos Malik
Modified: 2016-11-03 22:22 EDT (History)
7 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-94.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1333588 (view as bug list)
Environment:
Last Closed: 2016-11-03 22:22:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2015-09-18 06:45:13 EDT
Description of problem:

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-50.el7.noarch
selinux-policy-devel-3.13.1-50.el7.noarch
selinux-policy-doc-3.13.1-50.el7.noarch
selinux-policy-minimum-3.13.1-50.el7.noarch
selinux-policy-mls-3.13.1-50.el7.noarch
selinux-policy-sandbox-3.13.1-50.el7.noarch
selinux-policy-targeted-3.13.1-50.el7.noarch
storaged-2.1.1-1.el7.x86_64

How reproducible:
always

Steps to Reproduce:
# semanage fcontext -l | grep storaged
/usr/lib/storaged/storaged                         regular file       system_u:object_r:lvm_exec_t:s0 
/usr/lib/storaged/storaged-lvm-helper              regular file       system_u:object_r:lvm_exec_t:s0 
# ls -Z /usr/lib/storaged/storaged
ls: cannot access /usr/lib/storaged/storaged: No such file or directory
# ls -Z /usr/lib/storaged/storaged-lvm-helper
ls: cannot access /usr/lib/storaged/storaged-lvm-helper: No such file or directory
# ls -l /usr/libexec/storaged/storaged
-rwxr-xr-x. 1 root root 394728 Jul  6 12:18 /usr/libexec/storaged/storaged
# matchpathcon /usr/libexec/storaged/storaged 
/usr/libexec/storaged/storaged	system_u:object_r:bin_t:s0
# 

Actual results:
 * storaged runs as unconfined_service_t

Expected results:
 * storaged runs as lvm_t
Comment 1 Miroslav Grepl 2015-09-18 06:53:44 EDT
Did it come with 7.2? It looks like there storaged errata.
Comment 3 Lukas Vrabec 2016-05-05 18:41:00 EDT
fedora@fedora ~]$ ps -efZ | grep storaged
system_u:system_r:lvm_t:s0      root      3887     1  0 22:40 ?        00:00:00 /usr/libexec/storaged/storaged --no-debug
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 fedora 3894 741  0 22:40 pts/0 00:00:00 grep --color=auto storaged


Fixed in Fedora. We need back port this.
https://bugzilla.redhat.com/show_bug.cgi?id=1333588
Comment 11 errata-xmlrpc 2016-11-03 22:22:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html

Note You need to log in before you can comment on or make changes to this bug.