Bug 1264405 - Remove List<VdsNetworkInterface> nics from and pass only relevant information
Remove List<VdsNetworkInterface> nics from and pass only relevant information
Status: CLOSED NEXTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.0
Unspecified Unspecified
low Severity low (vote)
: ovirt-4.0.0-beta
: ---
Assigned To: Martin Mucha
: CodeChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 07:52 EDT by Martin Mucha
Modified: 2016-05-23 03:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-23 03:25:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.0?
rule-engine: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54413 master MERGED core: Do not pass VdsNetworkInterface as user overrides. 2016-03-23 08:24 EDT
oVirt gerrit 54414 master MERGED core: inlined overrideNicWithUserConfiguration 2016-03-23 08:25 EDT
oVirt gerrit 54415 master MERGED core: remove duplicate method getLabelToNic 2016-03-23 08:26 EDT

  None (edit)
Description Martin Mucha 2015-09-18 07:52:03 EDT
Description of problem:
it's little bit misleading, since two collections of dbNics are getting passed around, while one of which is passed only to update nics with label.

from CR: https://gerrit.ovirt.org/#/c/45298/5/backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/HostNetworkTopologyPersisterImpl.java

The nics in the userConfiguredData are used only to update the labels. We can pass a list of nicNameToLabel instead.
Comment 1 Yaniv Lavi 2015-10-21 05:29:45 EDT
Please explain what the impact is and how urgent it is?
Comment 2 Martin Mucha 2015-10-22 08:18:21 EDT
no impact, absolutely not urgent.

I was asked to fill a bug for it so we do not forget about it. 
It's just an design issue; to certain place is send information in overly generic datastructure; any extra stuff is simply ignored. It just make code more fragile and harder to understand.
Comment 3 Martin Mucha 2016-01-08 03:02:00 EST
should be done after other refactorings on UI in this area are done:
https://gerrit.ovirt.org/#/c/48544/
Comment 4 Sandro Bonazzola 2016-05-02 06:05:57 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.

Note You need to log in before you can comment on or make changes to this bug.