Bug 1264424 - change ovirt-engine api endpoint
change ovirt-engine api endpoint
Status: CLOSED CURRENTRELEASE
Product: ovirt-image-uploader
Classification: oVirt
Component: Core (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Rafael Martins
Gonza
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 08:37 EDT by Rafael Martins
Modified: 2016-07-05 03:39 EDT (History)
3 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Due to a change in ovirt-engine API endpoints, ovirt-image-uploader was unable to communicate with ovirt-engine. This issue has been resolved.
Story Points: ---
Clone Of:
: 1264542 (view as bug list)
Environment:
Last Closed: 2016-07-05 03:39:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: blocker+
bmcclain: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46374 master MERGED ovirt-image-uploader: fix ovirt-engine api url Never

  None (edit)
Description Rafael Martins 2015-09-18 08:37:39 EDT
The /api endpoint does not exists anymore in ovirt-engine's master. ovirt-image-uploader should point to /ovirt-engine/api, otherwise users will get a 404 error.
Comment 1 Sandro Bonazzola 2015-09-18 10:11:52 EDT
I guess iso-uploader and log-collector are affected as well. If so, please open a bz for them too.
Comment 2 Rafael Martins 2015-09-18 14:46:39 EDT
(In reply to Sandro Bonazzola from comment #1)
> I guess iso-uploader and log-collector are affected as well. If so, please
> open a bz for them too.

iso-uploader is affected, see bug #1264542. log-collector already uses the correct endpoint.
Comment 3 Gonza 2016-06-24 04:38:57 EDT
Verified with:
rhevm-4.0.0.5-0.1.el7ev.noarch

engine-image-uploader is correctly pointing to ovirt-engine/api endpoint but command fails due to bz1349774
Comment 4 Sandro Bonazzola 2016-07-05 03:39:30 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.