Bug 1264457 - FreeRADIUS 3.0.4-6 miscalculates MPPE keys with TLS 1.2
FreeRADIUS 3.0.4-6 miscalculates MPPE keys with TLS 1.2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: freeradius (Show other bugs)
7.1
Unspecified Linux
high Severity high
: rc
: ---
Assigned To: Nikolai Kondrashov
Jaroslav Aster
: TestOnly
Depends On: 1202751
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 09:45 EDT by Marcio
Modified: 2017-08-01 16:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 16:36:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcio 2015-09-18 09:45:09 EDT
Description of problem:
Same bug of FreeRADIUS 2.2.6 in RedHat el 6.

https://bugzilla.redhat.com/show_bug.cgi?id=1248484
Comment 2 Patrik Kis 2015-12-14 07:40:53 EST
This bug report seems to be not correct.
It mentions FreeRADIUS 2.2.6 but it is filed against RHEL-7. Note that RHEL-7 contains FreeRADIUS version 3 and AFAIK this issue is not present there.
Comment 5 Patrik Kis 2016-02-12 08:52:09 EST
IMHO this issue is not relevant for the currently shipped freeradius in RHEL-7 which is: freeradius-3.0.4

According to changelogs here http://freeradius.org/press/index.html#3.0.11
freeradius v3 TLS-1.2 support was added in version 3.0.5 and the issue reported here is fixed again in version 3.0.10.
Comment 10 Nikolai Kondrashov 2017-02-16 06:21:00 EST
This should be fixed in 3.0.12.
Comment 11 Nikolai Kondrashov 2017-02-21 09:31:00 EST
I think we should close this as NOTABUG (since the problem didn't exist in 3.0.4), once we verified this is not a problem in 3.0.12 either.
Comment 14 errata-xmlrpc 2017-08-01 16:36:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1954

Note You need to log in before you can comment on or make changes to this bug.