Bug 1264464 - [RFE][nova] include disk resize down
[RFE][nova] include disk resize down
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Eoghan Glynn
nlevinki
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 10:05 EDT by Eduard Barrera
Modified: 2017-07-18 13:54 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-18 13:54:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduard Barrera 2015-09-18 10:05:45 EDT
Description of problem:

Include this functionality to future releases

  Currently libvirt driver doesn't support resizing disk down.

     https://bugs.launchpad.net/nova/+bug/1270238



Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:

1. Create an instance
2. resize the flavor down
3.

Actual results:

During a resizing down all run well and the instance is updated to the new flavor with the new disk size.
but in real the disk is not resized and keep the original size.


Expected results:

Disk resized down too
Comment 5 Stephen Gordon 2017-07-18 13:54:27 EDT
The Nova API intentionally disallows resize down at this point due to inconsistencies in the ability to support this across various hypervisor drivers, and the inconsistent results such an operation would have to give based on how much of the disk has actually been used.

Note You need to log in before you can comment on or make changes to this bug.