Bug 1264473 - gi.overrides.BlockDev.BtrfsError: Process reported exit code 256: extent-tree.c:2694: btrfs_reserve_extent: Assertion `ret` failed. mkfs.btrfs(+0x13820)[0x2aac3393820] mkfs.btrfs(btrfs_reserve_extent+0x788)[0x2aac33980d0] mkfs.btrfs(btrfs_alloc_free_bl...
gi.overrides.BlockDev.BtrfsError: Process reported exit code 256: extent-tree...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: btrfs-progs (Show other bugs)
23
aarch64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Josef Bacik
Fedora Extras Quality Assurance
abrt_hash:3ff53274dbd6c495f0d135aa555...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 10:25 EDT by Paul Whalen
Modified: 2015-10-07 08:46 EDT (History)
9 users (show)

See Also:
Fixed In Version: btrfs-progs-4.2.1-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-07 08:46:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (430.35 KB, text/plain)
2015-09-18 10:25 EDT, Paul Whalen
no flags Details
File: anaconda.log (37.95 KB, text/plain)
2015-09-18 10:25 EDT, Paul Whalen
no flags Details
File: dnf.log (2.95 KB, text/plain)
2015-09-18 10:25 EDT, Paul Whalen
no flags Details
File: environ (459 bytes, text/plain)
2015-09-18 10:25 EDT, Paul Whalen
no flags Details
File: lsblk_output (1.67 KB, text/plain)
2015-09-18 10:25 EDT, Paul Whalen
no flags Details
File: nmcli_dev_list (1.94 KB, text/plain)
2015-09-18 10:25 EDT, Paul Whalen
no flags Details
File: os_info (451 bytes, text/plain)
2015-09-18 10:25 EDT, Paul Whalen
no flags Details
File: storage.log (181.18 KB, text/plain)
2015-09-18 10:25 EDT, Paul Whalen
no flags Details
File: syslog (54.54 KB, text/plain)
2015-09-18 10:25 EDT, Paul Whalen
no flags Details
File: ifcfg.log (7.18 KB, text/plain)
2015-09-18 10:25 EDT, Paul Whalen
no flags Details
File: packaging.log (488 bytes, text/plain)
2015-09-18 10:25 EDT, Paul Whalen
no flags Details
File: program.log (57.44 KB, application/octet-stream)
2015-09-18 10:25 EDT, Paul Whalen
no flags Details

  None (edit)
Description Paul Whalen 2015-09-18 10:25:21 EDT
Description of problem:
Installation of F23 Beta RC1 AArch64, custom partitioning with btrfs. 

Version-Release number of selected component:
anaconda-23.19.3-1

The following was filed automatically by anaconda:
anaconda 23.19.3-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/gi/overrides/BlockDev.py", line 416, in wrapped
    raise transform[1](msg)
  File "/usr/lib/python3.4/site-packages/blivet/devices/btrfs.py", line 432, in _create
    md_level=md_level)
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 455, in create
    self._create()
  File "/usr/lib/python3.4/site-packages/blivet/deviceaction.py", line 312, in execute
    self.device.create()
  File "/usr/lib/python3.4/site-packages/blivet/actionlist.py", line 280, in process
    action.execute(callbacks)
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 380, in processActions
    callbacks=callbacks)
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 164, in doIt
    self.devicetree.processActions(callbacks=callbacks)
  File "/usr/lib/python3.4/site-packages/blivet/osinstall.py", line 1074, in turnOnFilesystems
    storage.doIt(callbacks)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/install.py", line 195, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall, callbacks=callbacks_reg)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
gi.overrides.BlockDev.BtrfsError: Process reported exit code 256: extent-tree.c:2694: btrfs_reserve_extent: Assertion `ret` failed.
mkfs.btrfs(+0x13820)[0x2aac3393820]
mkfs.btrfs(btrfs_reserve_extent+0x788)[0x2aac33980d0]
mkfs.btrfs(btrfs_alloc_free_block+0x6c)[0x2aac33982d4]
mkfs.btrfs(__btrfs_cow_block+0xd4)[0x2aac338a834]
mkfs.btrfs(btrfs_search_slot+0x3d8)[0x2aac338d788]
mkfs.btrfs(btrfs_insert_empty_items+0x9c)[0x2aac338e864]
mkfs.btrfs(btrfs_insert_item+0x6c)[0x2aac338ec4c]
mkfs.btrfs(btrfs_make_block_group+0x50)[0x2aac33976b8]
mkfs.btrfs(main+0x81c)[0x2aac33886ac]
/lib64/libc.so.6(__libc_start_main+0xe4)[0x3ffb477f68c]
mkfs.btrfs(+0x9af4)[0x2aac3389af4]


Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-S-23_B-aarch64 ro
dnf.rpm.log:    Sep 18 14:20:15 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.aarch64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 1 Paul Whalen 2015-09-18 10:25:24 EDT
Created attachment 1074932 [details]
File: anaconda-tb
Comment 2 Paul Whalen 2015-09-18 10:25:25 EDT
Created attachment 1074933 [details]
File: anaconda.log
Comment 3 Paul Whalen 2015-09-18 10:25:26 EDT
Created attachment 1074934 [details]
File: dnf.log
Comment 4 Paul Whalen 2015-09-18 10:25:26 EDT
Created attachment 1074935 [details]
File: environ
Comment 5 Paul Whalen 2015-09-18 10:25:27 EDT
Created attachment 1074936 [details]
File: lsblk_output
Comment 6 Paul Whalen 2015-09-18 10:25:28 EDT
Created attachment 1074937 [details]
File: nmcli_dev_list
Comment 7 Paul Whalen 2015-09-18 10:25:29 EDT
Created attachment 1074938 [details]
File: os_info
Comment 8 Paul Whalen 2015-09-18 10:25:30 EDT
Created attachment 1074939 [details]
File: storage.log
Comment 9 Paul Whalen 2015-09-18 10:25:31 EDT
Created attachment 1074940 [details]
File: syslog
Comment 10 Paul Whalen 2015-09-18 10:25:32 EDT
Created attachment 1074941 [details]
File: ifcfg.log
Comment 11 Paul Whalen 2015-09-18 10:25:33 EDT
Created attachment 1074942 [details]
File: packaging.log
Comment 12 Paul Whalen 2015-09-18 10:25:34 EDT
Created attachment 1074943 [details]
File: program.log
Comment 13 David Shea 2015-09-18 11:40:16 EDT
Reassigning to btrfs-progs based on the apparent crash in mkfs.btrfs.
Comment 14 Richard W.M. Jones 2015-10-07 08:40:24 EDT
I can reproduce this on:

btrfs-progs-4.2-1.fc24.aarch64  (NB: aarch64)

$ truncate -s 1G test.img
$ mkfs.btrfs test.img 
btrfs-progs v4.2
See http://btrfs.wiki.kernel.org for more information.

extent-tree.c:2694: btrfs_reserve_extent: Assertion `ret` failed.
mkfs.btrfs(+0x13820)[0x2aada303820]
mkfs.btrfs(btrfs_reserve_extent+0x788)[0x2aada3080d0]
mkfs.btrfs(btrfs_alloc_free_block+0x6c)[0x2aada3082d4]
mkfs.btrfs(__btrfs_cow_block+0xd4)[0x2aada2fa834]
mkfs.btrfs(btrfs_search_slot+0x3d8)[0x2aada2fd788]
mkfs.btrfs(btrfs_insert_empty_items+0x9c)[0x2aada2fe864]
mkfs.btrfs(btrfs_insert_item+0x6c)[0x2aada2fec4c]
mkfs.btrfs(btrfs_make_block_group+0x50)[0x2aada3076b8]
mkfs.btrfs(main+0x81c)[0x2aada2f86ac]
/lib64/libc.so.6(__libc_start_main+0xe4)[0x3ff9e79f764]
mkfs.btrfs(+0x9af4)[0x2aada2f9af4]

However I cannot reproduce it on
btrfs-progs-4.2.1-1.fc24.x86_64
(NB: Increased version and x86)

So it could either have been fixed, or it might only affect aarch64.
Comment 15 Richard W.M. Jones 2015-10-07 08:46:54 EDT
This is fixed in 4.2.1-1, even on aarch64.  Therefore I am closing this bug.

Note You need to log in before you can comment on or make changes to this bug.