Bug 1264481 - ws-commons-util-1.0.2 is available
ws-commons-util-1.0.2 is available
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ws-commons-util (Show other bugs)
22
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: FutureFeature, Patch
Depends On:
Blocks: 1168605
  Show dependency treegraph
 
Reported: 2015-09-18 10:50 EDT by Sandro Bonazzola
Modified: 2015-09-25 07:21 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.0.2-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 11:41:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec update (4.08 KB, patch)
2015-09-18 11:16 EDT, Sandro Bonazzola
no flags Details | Diff
spec update (4.57 KB, patch)
2015-09-22 11:25 EDT, Sandro Bonazzola
no flags Details | Diff

  None (edit)
Description Sandro Bonazzola 2015-09-18 10:50:21 EDT
Latest upstream release: 1.0.2
Current version/release in fc22: 1.0.1-31.fc21
URL: http://central.maven.org/maven2/org/apache/ws/commons/util/ws-commons-util/ 

See: https://release-monitoring.org/project/7497/
Comment 1 Sandro Bonazzola 2015-09-18 11:16:21 EDT
Created attachment 1074967 [details]
spec update
Comment 2 gil cattaneo 2015-09-18 12:21:09 EDT
(In reply to Sandro Bonazzola from comment #1)
> Created attachment 1074967 [details]
> spec update

Please, add OSGi support. 
e.g.
%pom_xpath_inject "pom:project" "<packaging>bundle</packaging>"
%pom_add_plugin org.apache.felix:maven-bundle-plugin . '
<extensions>true</extensions>
<configuration>
  <instructions>
    <Bundle-SymbolicName>org.apache.ws.commons.util</Bundle-SymbolicName>
    <Bundle-Name>${project.name}</Bundle-Name>
    <Bundle-Localization>plugin</Bundle-Localization>
    <Bundle-Version>${project.version}</Bundle-Version>
  </instructions>
</configuration>
<executions>
  <execution>
    <id>bundle-manifest</id>
    <phase>process-classes</phase>
    <goals>
      <goal>manifest</goal>
    </goals>
  </execution>
</executions>'
Comment 3 gil cattaneo 2015-09-18 12:24:59 EDT
(In reply to Sandro Bonazzola from comment #1)
> Created attachment 1074967 [details]
> spec update

and do not overwrite the spec file %changelog
-* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.1-32
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
+* Fri Sep 18 2015 Sandro Bonazzola <sbonazzo@redhat.com> - 1.0.2-1
+- Resolves: BZ#1264481
Comment 4 Sandro Bonazzola 2015-09-22 11:25 EDT
Created attachment 1075885 [details]
spec update

Addressed Gil's comments
Comment 5 Mikolaj Izdebski 2015-09-22 11:37:55 EDT
Fixed in ws-commons-util-1.0.2-1
Comment 6 Mikolaj Izdebski 2015-09-22 11:41:42 EDT
I believe that this feature is included in ws-commons-util-1.0.2-1,
which is available in Fedora Rawhide, so I am closing this bug now.

The build which includes the feature can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=687069

This feature was included in the next release of Fedora, and it is currently
not planned to be included in the release it was requested for.
You can update to the newer release of Fedora to get the feature.
Comment 7 Sandro Bonazzola 2015-09-23 04:47:00 EDT
Thanks, no plan of back-porting to f23 (not out yet)?
Comment 8 Mikolaj Izdebski 2015-09-23 07:16:46 EDT
I don't plan to push this update to Fedora 23 because it's quite late in release cycle (beta was already released) and I don't want to risk breaking it.
Comment 9 Sandro Bonazzola 2015-09-25 07:21:45 EDT
Ok, thanks

Note You need to log in before you can comment on or make changes to this bug.