Bug 1264486 - drkonqi (sometimes) fails to start, blocks or slows plasmashell
drkonqi (sometimes) fails to start, blocks or slows plasmashell
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kwin (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Vrátil
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: plasma5
  Show dependency treegraph
 
Reported: 2015-09-18 11:01 EDT by Rex Dieter
Modified: 2016-05-15 05:47 EDT (History)
15 users (show)

See Also:
Fixed In Version: kde-runtime-15.08.1-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 12:37:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 353428 None None None 2016-03-01 12:37 EST

  None (edit)
Description Rex Dieter 2015-09-18 11:01:12 EDT
From a recent thread on kde mailing list, seems kde4 drkonqi gets called, but never shows and can cause plasmashell to block or slow greatly, see also:

https://lists.fedoraproject.org/pipermail/kde/2015-September/015662.html


Workarounds off the top of my head:
* make it possible to remove kde-runtime-drkonqi (it is currently a hard dep of kde-runtime)
* patch kdelibs/kde-runtime to be able to use plasma5's drkonqi


May be related, heliocastro on irc has a theory that plasma5 drkonqi and kde4 drkonqi conflict somehow, but we're not able to confirm that yet.
Comment 1 Terje Røsten 2015-09-21 04:50:50 EDT
This is also the reason #1224489 is very hard to recover from.
Comment 2 Fedora Update System 2015-09-26 11:44:59 EDT
kde-runtime-15.08.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2827d4eff6
Comment 3 Fedora Update System 2015-09-26 11:53:33 EDT
kde-runtime-15.08.1-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1aa1e090b4
Comment 4 Fedora Update System 2015-09-26 20:37:06 EDT
kde-runtime-15.08.1-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kde-runtime'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1aa1e090b4
Comment 5 Fedora Update System 2015-09-26 20:54:11 EDT
kde-runtime-15.08.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kde-runtime'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2827d4eff6
Comment 6 Robin Laing 2015-10-03 00:32:40 EDT
I had submitted a bug report for this under kwin as that was the process that kept being mentioned.  As I didn't know how to trace the bug then, I couldn't provide the necessary info.   It is closed for now.

https://bugs.kde.org/show_bug.cgi?id=353428

Just commenting for reference.

Robin
Comment 7 Rex Dieter 2015-10-03 08:22:48 EDT
fyi, It's not closed, but currently marked "Unconfirmed"
Comment 8 Fedora Update System 2015-10-03 13:35:54 EDT
kde-runtime-15.08.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Ed Greshko 2015-10-03 23:02:18 EDT
I have these installed as suggested in the KDE mailing list

[egreshko@meimei ~]$ rpm -qa | grep kde-runtime
kde-runtime-15.08.1-2.fc22.x86_64
kde-runtime-libs-15.08.1-2.fc22.x86_64
kde-runtime-flags-15.08.1-2.fc22.noarch

And I just had a situation where the screen "froze".  I was able to move the mouse around and the audio for the baseball game I was watching on MLB.tv continued to supply audio but, of course, frozen video.

killall -9 drkonqi

Restored everything
Comment 10 Rex Dieter 2015-10-03 23:15:30 EDT
So our initial analysis that kde4's drkonqi is causing this seems to be false, in your case.  The problem is that kf5's drkonqi is never being displayed.

Re-opening.
Comment 11 Rex Dieter 2015-10-03 23:16:45 EDT
Re-assigning to plasma-workspace (where drkonqi lives)
Comment 12 Robin Laing 2015-10-05 20:06:01 EDT
I will also add that it happened to me last night as well.  

kde-runtime-drkonqi-15.08.1-1.fc22.x86_64

Now that I am learning how to use gdb, I hope to add more if it happens again.

Notice that most of my issues are either with Firefox or Konsole.  If I have a konsole open, the title won't be visible as the konsole goes to the top of the screen.

Firefox has some issues.

Don't know if related but I had issues with LibreOffice 5 due to KDE3 libs being on my system.  I will monitor if there is any change.
Comment 13 Fedora Update System 2015-10-07 02:20:24 EDT
kde-runtime-15.08.1-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Rex Dieter 2016-03-01 12:37:50 EST
tracking upstream, fix landed there with kwin-5.6

Note You need to log in before you can comment on or make changes to this bug.