Bug 1264502 - pulp-puppet-module-builder fails when there are no 'Modulefile' metadata files
pulp-puppet-module-builder fails when there are no 'Modulefile' metadata files
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.1.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: satellite6-bugs
Kedar Bidarkar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 11:38 EDT by Jeremy Cline
Modified: 2017-07-26 15:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:19:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 1249 Normal CLOSED - CURRENTRELEASE pulp_module_builder fails when there are no 'ModuleFile' metadata files Never

  None (edit)
Description Jeremy Cline 2015-09-18 11:38:54 EDT
Description of problem:

Using pulp-puppet-module-builder on a set of puppet modules fails if one of them does not contain the old-style metadata file 'Modulefile'. 

Version-Release number of selected component (if applicable): 2.6.3


How reproducible: always
Comment 1 pulp-infra@redhat.com 2015-09-18 12:08:51 EDT
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.
Comment 2 pulp-infra@redhat.com 2015-09-18 12:08:52 EDT
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.
Comment 3 pulp-infra@redhat.com 2015-09-25 16:30:18 EDT
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.
Comment 5 pulp-infra@redhat.com 2015-10-22 11:00:38 EDT
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.
Comment 6 pulp-infra@redhat.com 2015-11-09 16:00:35 EST
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.
Comment 10 Kedar Bidarkar 2016-04-06 12:23:24 EDT
I feel this bug can be tested with puppet-modules that contain metadata.json 


[root@kbidrhel72cxlo tmp]# pulp-puppet-module-builder --url=https://github.com/puppetlabs/puppetlabs-xinetd
cd /tmp
git clone --recursive https://github.com/puppetlabs/puppetlabs-xinetd
cd puppetlabs-xinetd
git status
git remote show -n origin
git fetch
git fetch --tags
find . -name Modulefile -o -name metadata.json
puppet module build .
mkdir -p /tmp
cp ./pkg/puppetlabs-xinetd-1.5.0.tar.gz /tmp
cd /tmp
cd /tmp/puppetlabs-xinetd
cd /tmp
[root@kbidrhel72cxlo tmp]# ls
ks-script-E3uXj1  ks-script-MGHh4V  PULP_MANIFEST  puppetlabs-xinetd  puppetlabs-xinetd-1.5.0.tar.gz  yum.log  yum_save_tx.2016-04-06.15-46.lDqkAu.yumtx
[root@kbidrhel72cxlo tmp]# cd puppetlabs-xinetd
[root@kbidrhel72cxlo puppetlabs-xinetd]# ls
CHANGELOG.md  examples  Gemfile  LICENSE  manifests  metadata.json  pkg  Rakefile  README.md  spec  templates


VERIFIED With sat62-snap6.0
Comment 12 errata-xmlrpc 2016-07-27 05:19:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.