Bug 1264503 - Trying to build sssd in a Dockerfile that could be shared between RHEL and Fedora
Trying to build sssd in a Dockerfile that could be shared between RHEL and Fe...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freeipa (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: IPA Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 11:40 EDT by Daniel Walsh
Modified: 2016-12-15 10:08 EST (History)
12 users (show)

See Also:
Fixed In Version: freeipa-4.3.1-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 16:30:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2015-09-18 11:40:02 EDT
Goal was to just change from rhel7 to from fedora, but install of ipa-client fails.  Shouldn't freeipa-client have a provides ipa-client?
Comment 1 Jan Pazdziora 2015-09-21 02:34:18 EDT
(In reply to Daniel Walsh from comment #0)
> Goal was to just change from rhel7 to from fedora, but install of ipa-client
> fails.  Shouldn't freeipa-client have a provides ipa-client?

We had multiple discussions but the answer is not really.

The Dockerfiles are not transferrable between OSes anyway due to differences between RHEL and Fedora (at least, yum vs. dnf) so we just have multiple branches in https://github.com/adelton/docker-freeipa for different OSes, including clients.

If you need one source, you can try

   RUN yum install -y /usr/sbin/ipa-client-install
Comment 2 Daniel Walsh 2015-09-21 08:22:41 EDT
I understand that but freeipa-client does provide the exact same functionality of ipa-client.  Forgetting about the Dockerfile argument, even though the only thing I had to change to play with  your Dockerfile was to change from line and freeipa-client line.  yum works in Fedora with the failover.  But if you don't want to provide it, fine.  Close the bug.
Comment 3 Simo Sorce 2015-09-22 21:43:13 EDT
Jan what is the problem of adding a 
Provides: ipa-client
line to the freeipa-client spec file ?
Comment 6 Simo Sorce 2015-09-24 09:28:25 EDT
The reason is largely historical and has to do with branding efforts we had back then. There is no other good reason to keep the names different other than changing them is unnecessary churn. Hence trhe provides which allows you to have a single yum/dnf command for any distro.
Comment 7 Petr Vobornik 2015-10-26 11:02:57 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5408
Comment 8 Jan Cholasta 2015-11-12 03:54:53 EST
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/ab58ec0d50f172093e75b7834f6ed5e39992c2d9
Comment 9 Tomas Babej 2016-02-08 10:18:17 EST
Necessary information has already been provided.
Comment 10 Jan Kurik 2016-02-24 08:46:12 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 11 Fedora Update System 2016-03-24 16:47:32 EDT
freeipa-4.3.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f6e2d255aa
Comment 12 Fedora Update System 2016-03-25 16:27:43 EDT
freeipa-4.3.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f6e2d255aa
Comment 13 Fedora Update System 2016-03-31 16:30:34 EDT
freeipa-4.3.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Martin Bašti 2016-12-15 10:08:24 EST
Fix for this causes yum (and recently we found that DNF issues too in some cases) issues: https://bugzilla.redhat.com/show_bug.cgi?id=1370134 and there is getting to be serious chance that this fix may be reverted.

If you disagree with revert please say it now and provide reasoning why not (comments above are not enough).

Note You need to log in before you can comment on or make changes to this bug.