Bug 126451 - missing dependancy for libxml2-python for rhpl
Summary: missing dependancy for libxml2-python for rhpl
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rhpl   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-21 20:09 UTC by Matt Jamison
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 20:21:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matt Jamison 2004-06-21 20:09:17 UTC
there seems to be a dependancy error while trying to register my
client with rhn_register.  it looks like there is a missing dependancy
in rhpl for libxml2-python

[root@dhcp204 root]# rhn_register
Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 29, in ?
    from up2date_client import up2date
  File "up2date.py", line 36, in ?
  File "depSolver.py", line 4, in ?
  File "packageList.py", line 17, in ?
  File "up2dateComps.py", line 7, in ?
  File "/usr/lib/python2.2/site-packages/rhpl/comps.py", line 5, in ?
    import libxml2
ImportError: No module named libxml2

Comment 1 Jeremy Katz 2004-06-21 20:21:03 UTC
rhpl is a jack of all trades package that is required on pretty much
all installs.  Adding extra dependencies bloats the default install
unnecessarily -- instead, packages which depend on specific rhpl
functionality should add the appropriate lower level requires.


Note You need to log in before you can comment on or make changes to this bug.