Bug 1264518 - qdrouterd should have configurable heartbeats for listeners and connectors
Summary: qdrouterd should have configurable heartbeats for listeners and connectors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Infrastructure
Version: 6.1.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-18 16:28 UTC by Stuart Auchterlonie
Modified: 2019-08-15 05:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-15 18:20:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1911 0 normal SHIPPED_LIVE Satellite 6.1.3 bug fix update 2015-10-15 22:19:19 UTC

Description Stuart Auchterlonie 2015-09-18 16:28:26 UTC
Description of problem:

As part of investigation into https://bugzilla.redhat.com/show_bug.cgi?id=1264509
it was identified that qdrouterd was persisting in attempts to use
connections from the satellite to the capsule which were no longer open
on the capsule side.

Upstream issue https://issues.apache.org/jira/browse/DISPATCH-144
was opened to track this work

Version-Release number of selected component (if applicable):

qpid-dispatch-router-0.4-7.el7.x86_64

How reproducible:

1/1 attempt

Steps to Reproduce:
1. Use iptables on capsule to drop all port 5647 traffic to and from the satellite
2. Allow the existing ongoing connections to die off on the capsule side.
I left mine running in this state overnight

Actual results:

qdrouterd persists in using connections which appear to be open
on from sat -> capsule, which are no longer connected on the capsule
as the capsule client has already torn them down.

Expected results:

qdrouterd tears down connections which are no longer operating
and replaces them with new connections.

Additional info:

Comment 5 jcallaha 2015-10-08 13:42:19 UTC
Verified on Satellite-6.1.0-20151006.0

In and Out connections on 5647 dropped for an entire night then brought back. Was able to install and remove packages with no errors.

Comment 7 errata-xmlrpc 2015-10-15 18:20:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1911


Note You need to log in before you can comment on or make changes to this bug.