Bug 1264578 - Web Console SSL config
Web Console SSL config
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: brice
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 17:30 EDT by Ryan Howe
Modified: 2016-05-19 19:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-19 19:22:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2015-09-18 17:30:25 EDT
Document URL: https://docs.openshift.com/enterprise/3.0/architecture/infrastructure_components/web_console.html
Section Number and Name: web console 

Describe the issue: 

- Need more information on what certs the webconsole uses and what all needs configured to add signed cert. 

Suggestions for improvement: 

Overview and details on where configuration is so that users can have a verified signed cert. 


Additional information:
Comment 2 brice 2016-04-20 01:57:51 EDT
Ryan,

I could be wrong, but it looks like this was documented here:

https://github.com/openshift/openshift-
docs/blob/master/install_config/certificate_customization.adoc

I put in the github link so you can see the history. 

Is there any elaboration needed, or do you think the information here is enough to fulfill this BZ?

Thanks!
Comment 3 brice 2016-05-15 22:06:03 EDT
Ryan,

It's been a while, but I'll bump this. There hasn't been much change in the cert docs since my last comment, but here it is live:

https://docs.openshift.com/enterprise/3.2/install_config/certificate_customization.html

If you think anything needs to be elaborated on, please let me know.
Comment 4 Ryan Howe 2016-05-19 18:13:06 EDT
That link is what we were looking for. I ok if we close this.
Comment 5 brice 2016-05-19 19:22:13 EDT
Ryan,

Fantastic. Thanks for the comment. I'll move this to closed.

Released content is here:

https://docs.openshift.com/enterprise/3.2/install_config/certificate_customization.html

Note You need to log in before you can comment on or make changes to this bug.