This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1264587 - [abrt] dnf: option_parser.py:273:get_usage:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 40: ordinal not in range(128)
[abrt] dnf: option_parser.py:273:get_usage:UnicodeDecodeError: 'ascii' codec ...
Status: CLOSED DUPLICATE of bug 1262082
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:79171f8ac3867eff31443432a22...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 18:15 EDT by Jorge Martínez López
Modified: 2016-01-01 15:28 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-21 04:50:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (4.06 KB, text/plain)
2015-09-18 18:15 EDT, Jorge Martínez López
no flags Details
File: environ (2.04 KB, text/plain)
2015-09-18 18:15 EDT, Jorge Martínez López
no flags Details

  None (edit)
Description Jorge Martínez López 2015-09-18 18:15:13 EDT
Description of problem:
$sudo dnf --refresh update

Version-Release number of selected component:
dnf-1.1.1-2.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python -OO /bin/dnf --refresh update
dso_list:       python-dnf-1.1.1-2.fc22.noarch
executable:     /bin/dnf
kernel:         4.1.6-201.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
#1 get_usage in /usr/lib/python2.7/site-packages/dnf/cli/option_parser.py:273
#2 configure in /usr/lib/python2.7/site-packages/dnf/cli/cli.py:1007
#3 _main in /usr/lib/python2.7/site-packages/dnf/cli/main.py:117
#4 main in /usr/lib/python2.7/site-packages/dnf/cli/main.py:84
#5 user_main in /usr/lib/python2.7/site-packages/dnf/cli/main.py:198
#6 <module> in /bin/dnf:36
Comment 1 Jorge Martínez López 2015-09-18 18:15:17 EDT
Created attachment 1075087 [details]
File: backtrace
Comment 2 Jorge Martínez López 2015-09-18 18:15:19 EDT
Created attachment 1075088 [details]
File: environ
Comment 3 Jorge Martínez López 2015-09-18 18:16:36 EDT
Workaround: 

# LANG="en_GB" dnf --refresh update
Comment 4 Aeder 2015-09-19 09:11:56 EDT
Another user experienced a similar problem:

Using any command causes dnf to crash. The problems started after a recent update.

reporter:       libreport-2.6.2
cmdline:        /usr/bin/python -OO /usr/bin/dnf install dnf-plugin-system-upgrade --enablerepo=updates-testing
dso_list:       python-dnf-1.1.1-2.fc22.noarch
event_log:      2015-09-19-10:10:16> ('report_uReport' completado con éxito)
executable:     /usr/bin/dnf
kernel:         4.1.6-201.fc22.x86_64
package:        dnf-1.1.1-2.fc22
reason:         option_parser.py:273:get_usage:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 40: ordinal not in range(128)
runlevel:       N 5
type:           Python
uid:            0
Comment 5 Juan Orti 2015-09-21 03:43:59 EDT
Another user experienced a similar problem:

dnf upgrade

reporter:       libreport-2.6.2
cmdline:        /usr/bin/python -OO /bin/dnf upgrade
dso_list:       python-dnf-1.1.1-2.fc22.noarch
event_log:      2015-09-21-09:43:39> ('report_uReport' completado con éxito)
executable:     /bin/dnf
kernel:         4.1.6-201.fc22.x86_64
package:        dnf-1.1.1-2.fc22
reason:         option_parser.py:273:get_usage:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 40: ordinal not in range(128)
runlevel:       N 5
type:           Python
uid:            0
Comment 6 Radek Holy 2015-09-21 04:50:57 EDT

*** This bug has been marked as a duplicate of bug 1262082 ***

Note You need to log in before you can comment on or make changes to this bug.