Bug 1264623 - nodejs-co needs nodejs engine 0.12 which is not in Fedora
nodejs-co needs nodejs engine 0.12 which is not in Fedora
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nodejs-co (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Piotr Popieluch
Fedora Extras Quality Assurance
: Reopened
Depends On: 1242926
Blocks: 1239730
  Show dependency treegraph
 
Reported: 2015-09-19 08:17 EDT by Piotr Popieluch
Modified: 2015-10-31 22:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: nodejs-co-3.1.0-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-31 22:35:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piotr Popieluch 2015-09-19 08:17:40 EDT
Description of problem:

Node.js module co needs Node.js 0.12 to function, it uses the "Promise" which is introduced in 0.12. This is specified in package.json, but is packages.json is modified in %prep to allow for 0.10. 




Version-Release number of selected component (if applicable):


How reproducible:
use the nodejs-co module, for example by rebuilding nodejs-pac-resolver:

 /usr/lib/node_modules/co/index.js:49
  return new Promise(function(resolve, reject) {
             ^
ReferenceError: Promise is not defined
    at co (/usr/lib/node_modules/co/index.js:49:14)
    at generate (/builddir/build/BUILD/package/index.js:105:18)
    at Suite.<anonymous> (/builddir/build/BUILD/package/test/test.js:38:27)
    at context.describe.context.context (/usr/lib/node_modules/mocha/lib/interfaces/bdd.js:73:10)
    at Suite.<anonymous> (/builddir/build/BUILD/package/test/test.js:37:3)
    at context.describe.context.context (/usr/lib/node_modules/mocha/lib/interfaces/bdd.js:73:10)
    at Object.<anonymous> (/builddir/build/BUILD/package/test/test.js:9:1)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at /usr/lib/node_modules/mocha/lib/mocha.js:172:27
    at Array.forEach (native)
    at Mocha.loadFiles (/usr/lib/node_modules/mocha/lib/mocha.js:169:14)
    at Mocha.run (/usr/lib/node_modules/mocha/lib/mocha.js:356:31)
    at Object.<anonymous> (/usr/lib/node_modules/mocha/bin/_mocha:359:16)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:929:3



Steps to Reproduce:
1. cd fedscm/nodejs-pac-resolver
2. fedpkg build
3.

Actual results:
Tests fail when nodejs-co is called which needs Promise which is not in current nodejs.

Expected results:


Additional info:
Comment 1 Parag AN(पराग) 2015-09-19 09:21:47 EDT
I think this is not that simple, someone needs to lead this update to node.js 0.12 version.

I see T.C. Hollingsworth tried to submit that as F23 Change but Change itself could not see any further update and hence FESCo decided to drop it.

Maybe this can be submitted again for F24.

I have not looked into above reported comment but just this bug summary and this is my view on it.
Comment 2 Piotr Popieluch 2015-09-19 14:08:53 EDT
Yes this isn't simple.

Update nodejs-co to >= 4 should have waited until node 0.12 would be in Fedora. Ideas to fix this:

1) rollback the update to 4.0
  afaik this is not possible

2) wait until 0.12 is in Fedora
  I can't find any status update on the change. Maybe we can help TC?

3) Multiversion nodejs-co and create a new nodejs-co3 package
  no good experience, My last multiversion attempt got stalled somewhere in review..

4) patch co to support some other "Promise" library which we have in 0.10
  Seems like a lot of work which will be thrown away when 2 will be completed
Comment 3 Piotr Popieluch 2015-09-19 14:59:00 EDT
Can we use epoch to accomplish a downgrade to version 0.3? (Option 1)
Comment 4 Parag AN(पराग) 2015-09-22 05:33:42 EDT
yes we can use epoch and downgrade to previous versions.
Comment 5 Piotr Popieluch 2015-09-22 13:29:31 EDT
bumped epoch and downgraded, built in rawhide.
nodejs-pac-resolver also builds now
Comment 6 Fedora Update System 2015-10-16 17:49:21 EDT
nodejs-co-3.1.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-599c23e343
Comment 7 Fedora Update System 2015-10-17 14:21:17 EDT
nodejs-co-3.1.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update nodejs-co'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-599c23e343
Comment 8 Fedora Update System 2015-10-31 22:35:33 EDT
nodejs-co-3.1.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.