Bug 1264628 - Label #1533 "_Network source:" aligned to the left, others too
Label #1533 "_Network source:" aligned to the left, others too
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-19 10:40 EDT by João Pirralha
Modified: 2015-09-20 13:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-20 13:00:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description João Pirralha 2015-09-19 10:40:02 EDT
Description of problem:
The label #1533 "_Network source:" is aligned to the left but should be aligned to the right, as happens with the other labels. Some other labels are misaligned too (see Additional info).

Version-Release number of selected component (if applicable):
Commit 9a4f15f4ad947b5689d0174276929c16e233b610

How reproducible:
Might only be reproducible in some locales due to the string length.

Steps to Reproduce:
1. Open a virtual machine in virt-manager
2. Go to "Show virtual hardware details"
3. Go to "NIC :xx:xx:xx"

Actual results: 
"_Network source:" is aligned to the left.

Expected results:
"_Network source:" should be aligned to the right.

Additional info:
Used locale: pt
There are more labels aligned to the left in Overview, Boot options and "M_odel:" in CPUs, but they don't look as bad/out of place as this one. Might be in more places.
Comment 1 Cole Robinson 2015-09-20 13:00:43 EDT
Thanks for the report João! Fixed upstream now:

commit b6111b5e850d347132975ffbfd2cfb176d334c58
Author: Cole Robinson <crobinso@redhat.com>
Date:   Sun Sep 20 12:58:23 2015 -0400

    details: Fix misaligned labels (bz 1264628)
    
    Shows up with different sized translation strings
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1264628
    
    Reported-by: João Pirralha <joaopirralha@gmail.com>

Note You need to log in before you can comment on or make changes to this bug.