Bug 1264632 - PackageKit tries to install F22 version of package and fails to download it
PackageKit tries to install F22 version of package and fails to download it
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-19 11:28 EDT by Jiri Eischmann
Modified: 2015-10-21 04:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 04:31:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Eischmann 2015-09-19 11:28:02 EDT
Description of problem:
When I try to install a package via PackageKit (either pkcon or gnome-software), it tries to install a F22 version of the package and fails to download it.

It happens with any package I've tried, all of them have F23 versions in Fedora repositories.

Version-Release number of selected component (if applicable):
1.0.9-1

How reproducible:
pkcon install gnome-sudoku

Actual results:
cannot download Packages/g/gnome-sudoku-3.16.0-1.fc22.x86_64.rpm to /var/cache/PackageKit/metadata/fedora/packages/: Cannot download Packages/g/gnome-sudoku-3.16.0-1.fc22.x86_64.rpm: All mirrors were tried

Expected results:
The correct (F23) package gets installed.

Additional info:
I did a fresh installation of F23, but I kept /home.
Comment 1 Kalev Lember 2015-10-21 04:31:55 EDT
This was due to outdated PackageKit-cached-metadata package. We now got rid of the package for F23 and are putting cached metadata on the images directly during the compose, making it all automatic. Should be fixed starting with http://koji.fedoraproject.org/koji/taskinfo?taskID=11520222 and newer image builds.

Note You need to log in before you can comment on or make changes to this bug.