Bug 126464 - hard lockup when using GL apps and mga driver
hard lockup when using GL apps and mga driver
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-21 22:30 EDT by Steffen Kluge
Modified: 2015-01-04 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:10:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steffen Kluge 2004-06-21 22:30:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
Using the mga driver with a Matrox Millennium G400MAX, and the mga
kernel module.

When enabling DRI in xorg.conf as per usual, and running any GL app,
the machine locks up hard (can't be pinged from other hosts).

Nothing is being logged to /var/log/{messages,Xorg.0.log}.

DRI/GL was working as advertised in RH9, using the same HW, same X11
config.

glxinfo works, and shows that direct rendering is enabled, but running
glxgears, or any of the GL screen savers, causes an instant system freeze.



Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Always

Steps to Reproduce:
1.configure xorg.conf to include DRI support
2.run glxgears
3.
    

Actual Results:  Instant freeze of the system, no reaction to
anything, including ping from remote systems.

Additional info:

kernel-2.6.6-1.435
Gigabyte 7IX board (AMD756 chipset)
Athlon Slot-A 600MHz
640MB RAM
Matrox G400MAX 32MB AGP
Comment 1 Mike A. Harris 2004-07-05 17:22:36 EDT
I heard rumors as of late, that there was an ABI incompatible change
somewhere between XFree86 4.3.0 and XOrg 6.7.0/XFree86 4.4.0 which
breaks the mga DRI, however I haven't confirmed wether this rumor
is correct or not yet.  In the mean time you might want to post
a message to one of the DRI mailing lists in case anyone else has
insight.  Let me know what you find out.  If there's a sane and
simple fix, I'll investigate including it into a future update.

Thanks for the report.
Comment 2 Steffen Kluge 2004-07-06 02:13:00 EDT
I've had a look around at the dri-users list, and the only relevant
recent thread I cound find was this one:
http://sourceforge.net/mailarchive/message.php?msg_id=8534255
If I find anything else I'll post it. 

It was slightly disturbing for me to read that there have been
lingering  problems with mga and dri all along. I always thought it
was working pretty well (up to XF86-4.3). I sure hope the mga driver
doesn't go down the drain. For 2D I haven't found any cards that
produce image quality comparable to the Matroxes.

Cheers
Steffen.
Comment 3 Sam Ockman 2004-07-23 20:48:37 EDT
I seem to have run into this same problem.  For weeks on my home
computer I couldn't get X to run anymore, it would just lock up hard
when I typed startx or tried to run the auto configuration program
that's part of setup. (I didn't spend too much time trying to fix it
either....just switched to my notebook.)

But today I found this bug, commented out all the lines having to do
with dri in my xorg.conf file, and everything seems to work again!

Fedora core 2 with a Matrox Millenium G450 on a Pentium IV 3.2 Ghz
workstation. 
Comment 4 Steffen Kluge 2004-09-21 21:31:49 EDT
Hi,
seeing that the bug has been assigned now I'd like to give this update:

The problem went away when I turned from the stock FC2 2.6.6 kernel to
a vanilla (kernel.org) 2.6.7 kernel. I haven't tested the (now
available) FC2 2.6.7 kernels, so I can't say whether the issue was a
2.6.6 vs 2.6.7 or a FC2 vs vanilla kernel one.

In any case, DRI now works just as well as it used to in RH9. I
wouldn't mind if this bug was closed, unless there is a lot of
curiosity about what went wrong in conjunction with the 2.6.6 FC2 kernel.

Cheers
Steffen.
Comment 5 Nick Richards 2004-10-03 13:41:26 EDT
Athlon 64 3000+, Asus K8Txx motherboard, Matrox G550 with both
proprietory and open X drivers.

This problem still occurs on FC2 kernel 2.6.8.1-521 (the latest
update) on both i386 and x86_64. Haen't yet tried a stock kernel.org
kernel/ FC3 Test 2, I'll give one a go if I get time next week. But
the Fedora bug shouldn't be closed as the problem still occurs in a
shipping product. Surely, 'go and use a vanilla kernel' shouldn't be
the Fedora response to a hard crash like this.
Comment 6 Dave Jones 2005-04-16 01:10:37 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.