Bug 1264672 - lilypond-fonts-common broken dependencies
lilypond-fonts-common broken dependencies
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lilypond (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-20 09:18 EDT by Tom Horsley
Modified: 2016-04-01 16:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-01 16:48:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2015-09-20 09:18:21 EDT
Description of problem:

Usually these dependency errors eventually go away, but I've been getting this from dnf for a week or so now:

Skipping packages with broken dependencies:
 lilypond-fonts-common      noarch      2.19.26-1.fc22       updates       31 k

Unfortunately, dnf doesn't say what the dependency error was, it just says there was an error.

Version-Release number of selected component (if applicable):
Currently installed version is lilypond-fonts-common-2.19.25-1.fc22.noarch

How reproducible:
every time

Steps to Reproduce:
1.dnf update
2.get unexplained dependency error
3.

Actual results:
no update

Expected results:
update

Additional info:
I've even run dnf clean all and a new dnf update with the same error every time.
Comment 1 Tom Horsley 2015-09-20 09:27:25 EDT
If I use yum-deprecated, I actually get the dependency problem explained:

Resolving Dependencies
--> Running transaction check
---> Package lilypond-fonts-common.noarch 0:2.19.25-1.fc22 will be updated
--> Processing Dependency: lilypond-fonts-common = 2.19.25-1.fc22 for package: lilypond-century-schoolbook-l-fonts-2.19.25-1.fc22.noarch
---> Package lilypond-fonts-common.noarch 0:2.19.26-1.fc22 will be an update
--> Finished Dependency Resolution
Error: Package: lilypond-century-schoolbook-l-fonts-2.19.25-1.fc22.noarch (installed)
           Requires: lilypond-fonts-common = 2.19.25-1.fc22
           Removing: lilypond-fonts-common-2.19.25-1.fc22.noarch (installed)
               lilypond-fonts-common = 2.19.25-1.fc22
           Updated By: lilypond-fonts-common-2.19.26-1.fc22.noarch (updates)
               lilypond-fonts-common = 2.19.26-1.fc22
           Available: lilypond-fonts-common-2.19.19-1.fc22.noarch (fedora)
               lilypond-fonts-common = 2.19.19-1.fc22
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

So apparently lilypond-fonts-common is new in the repos, but lilypond-century-schoolbook-l-fonts does not have a new version available.
Comment 2 Michael Schwendt 2015-09-20 09:34:29 EDT
Information for build lilypond-2.19.27-1.fc22
http://koji.fedoraproject.org/koji/buildinfo?buildID=684854
 -> f22-updates-testing

http://pkgs.fedoraproject.org/cgit/lilypond.git/commit/?id=1add3af2c308db490fed5e2e0ccec5ca37705333

Note You need to log in before you can comment on or make changes to this bug.