Bug 126471 - KON console makes a mess of displaying Japanese
Summary: KON console makes a mess of displaying Japanese
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kon2   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-22 06:57 UTC by Nathan B
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 05:17:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nathan B 2004-06-22 06:57:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
The KON console doesn't do what it's supposed to do... display 
Japanese characters properly.

Japanese character sets were installed at install time, and Japanese 
was set as the default language. Naturally enough, no Japanese is 
visible from the command line until the kon terminal is started. When 
it *is* started, a mish-mash of Japanese comes out when bash errors 
happen, or when a Japanese man page is accessed.

I heard that some Japanese character sets were pulled out of Fedora 
during Fedora 2's testing stages. Maybe this is the cause.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install computer with Japanese character sets.
2. start KON with the command "kon" from command prompt.
3. Make a command guaranteed to give Japanese output (such as "man 
fstab")
4. Try and decipher the garbage
    

Actual Results:  I couldn't read anything because what came out was 
definitely NOT legible Japanese!

Expected Results:  I should have been able to read the man page in 
Japanese.

Additional info:

Comment 1 Bill Nottingham 2004-08-05 21:38:43 UTC
I believe kon doesn't support UTF-8, correct?

Comment 2 Eido Inoue 2004-08-06 02:12:59 UTC
is the LANG set to ja_JP.UTF-8 or ja_JP.eucJP ? kon only supports the
legacy euc-jp encoding.

Comment 3 Akira TAGOH 2004-08-12 11:34:13 UTC
Yes, right. although it's the enhancement, since we have done UTF-8
locale transition, it's important problem unless we drop it. I'm
wondering if kon2 is prefered rather than bogl.
Actually PC to which kon2 doesn't work is growing.

Comment 6 Leon Ho 2006-07-13 05:17:35 UTC
kon2 is replaced with bterm in latest Fedora. Please open a new bug if you see
any problem in bterm.


Note You need to log in before you can comment on or make changes to this bug.