This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1264726 - During block-commit, stop guest, qemu will be unresponsive until commit job finished
During block-commit, stop guest, qemu will be unresponsive until commit job f...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Jeff Cody
FuXiangChun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-20 23:09 EDT by Pei Zhang
Modified: 2016-11-07 15:39 EST (History)
10 users (show)

See Also:
Fixed In Version: qemu 2.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-07 15:39:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Jeff Cody 2015-09-25 15:32:24 EDT
I have been able to reproduce this bug, by doing a block-commit on the active layer (as written up in the description).  This also does not occur upstream.

Looking in GDB, we are in aio_poll & bdrv_drain_all, but I have not pinpointed a particular patch as a fix.

This should not result in any data loss, as the job should run to completion, and even if stopped early the chain should still be intact.  However, it is a bad user experience, as it is not known how long it will be until QEMU is responsive again (and it could potentially be a long time, if there is a lot of data to commit).
Comment 5 Mike McCune 2016-03-28 18:44:25 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 FuXiangChun 2016-09-14 01:47:41 EDT
according to comment0.
verified this bug with qemu-kvm-rhev-2.6.0-24.

qemu-kvm active during block-mirror.

so, This bug is fixed.
Comment 9 errata-xmlrpc 2016-11-07 15:39:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html

Note You need to log in before you can comment on or make changes to this bug.