Bug 1264727 - systemctl is-active reports "unknown" after recent systemd udpate
systemctl is-active reports "unknown" after recent systemd udpate
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 00:08 EDT by Paul DeStefano
Modified: 2015-09-22 03:20 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 03:20:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul DeStefano 2015-09-21 00:08:23 EDT
Description of problem:

$ /bin/systemctl is-active sshd.service
unknown


Version-Release number of selected component (if applicable):
systemd-219-21.fc22.x86_64

How reproducible:
always since update

Steps to Reproduce:
1. run 'systemctl is-active' for any service
2.
3.

Actual results:
"unknown"

Expected results:
as documented in manual pages
Comment 1 Jan Synacek 2015-09-21 03:10:58 EDT
(In reply to Paul DeStefano from comment #0)
> How reproducible:
> always since update

From which version to which version? Does the command work if you put SELinux to permissive?
Comment 2 Paul DeStefano 2015-09-21 13:08:24 EDT
Ah, okay.  I didn't reboot after systemd upgrade and, after rebooting, this symptom was gone and it wasn't broken.  I assume that is expected?  I've certainty upgraded systemd in the past and not had this problem before rebooting, but perhaps this behavior doesn't surprise others.

Not sure how best to answer your question.  dnf.rpm.log shows
CLEANUP: systemd-219-19.fc22.x86_64
right after the upgrade to this version, so I'm guessing that was the previously installed version.
Comment 3 Jan Synacek 2015-09-22 03:20:32 EDT
You should always reboot if you are updating the init daemon (systemd).

So, after reboot, this issue is not reproducible anymore.

Note You need to log in before you can comment on or make changes to this bug.