Bug 1264728 - Allow EEH on spapr-pci-host-bridge
Summary: Allow EEH on spapr-pci-host-bridge
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: ppc64le
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: David Gibson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1259556
Blocks: 1288337 RHV4.1PPC
TreeView+ depends on / blocked
 
Reported: 2015-09-21 04:35 UTC by David Gibson
Modified: 2016-11-07 20:39 UTC (History)
11 users (show)

Fixed In Version: qemu-2.6
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 20:39:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description David Gibson 2015-09-21 04:35:13 UTC
Description of problem:

In the current qemu code, IBM's EEH (Enhanced Error Handling) functionality is only available for VFIO passthrough devices placed on the special spapr-pci-vfio-host-bridge.

That doesn't work well with current libvirt and RHEV, because they generally use use the plain spapr-pci-host-bridge device in the guest.

Version-Release number of selected component (if applicable):

qemu-kvm-rhev-2.3.0-24.el7.ppc64le

How reproducible:

100%

Steps to Reproduce:
1. Create a pseries VM with a VFIO device attached to an spapr-pci-host-bridge PHB.
2. Boot the guest
3. Attempt EEH actions on the passed through device

Actual results:

EEH actions will fail with RTAS errors

Expected results:

EEH operations complete successfully.

Additional info:

I'm not really sure if this meets the criteria for a blocker bug, but I'm filing it that way, because I think it should at least be assessed.

Comment 1 David Gibson 2015-09-21 05:34:37 UTC
I have posted upstream patches to address this (though they're minimally tested and not merged).

I've made a preliminary downstream port at:
    git://git.engineering.redhat.com/~dgibson/qemu.git
    branch 'rhel7/bz1264728'

Test build of same at http://brewweb.devel.redhat.com/brew/taskinfo?taskID=9858641

Comment 2 David Gibson 2015-09-25 01:37:27 UTC
Decision has been made not to try to rush to get EEH fully working in RHEL7.2.

Bumping to RHEL7.3.

Comment 3 David Gibson 2015-09-25 01:38:06 UTC
Moving back to assigned state, since the posted patches will need a respin anyway.

Comment 5 David Gibson 2015-11-20 05:43:01 UTC
I've now posted a reworked upstream series for this as RFC.

Comment 6 Zhengtong 2015-12-08 04:49:42 UTC
Hi David, is it possible that spapr-pci-vfio-host-bridge will be abandoned in future? and all the functions and devices will be implemented on  spapr-pci-host-bridge?

Comment 7 David Gibson 2015-12-08 23:06:47 UTC
Zhengtong,

Yes, that is my intention.

Comment 11 errata-xmlrpc 2016-11-07 20:39:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.