Bug 1264739 - Why abrt not catch crashes of Xorg server?
Why abrt not catch crashes of Xorg server?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1246373
  Show dependency treegraph
 
Reported: 2015-09-21 02:22 EDT by Mikhail
Modified: 2015-10-31 12:09 EDT (History)
8 users (show)

See Also:
Fixed In Version: abrt-2.7.0-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-31 12:09:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (31.28 KB, text/plain)
2015-09-21 02:22 EDT, Mikhail
no flags Details
dmesg.log (335.29 KB, text/plain)
2015-09-21 02:23 EDT, Mikhail
no flags Details
system.log (5.63 MB, text/x-vhdl)
2015-09-21 02:24 EDT, Mikhail
no flags Details
journal.log (7.41 MB, text/x-vhdl)
2015-10-15 16:15 EDT, Mikhail
no flags Details
Xorg.log (32.80 KB, text/plain)
2015-10-15 16:16 EDT, Mikhail
no flags Details
screenshot (57.12 KB, image/png)
2015-10-19 09:32 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2015-09-21 02:22:53 EDT
Created attachment 1075387 [details]
Xorg.0.log

Description of problem:


This problem I not see in gnome-abrt

[ 60244.259] (EE) 
[ 60244.259] (EE) Backtrace:
[ 60244.262] (EE) 0: /usr/libexec/Xorg (OsLookupColor+0x139) [0x59add9]
[ 60244.264] (EE) 1: /lib64/libc.so.6 (__restore_rt+0x0) [0x7f61be425b1f]
[ 60244.266] (EE) 2: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0xa9fc) [0x7f61b903116c]
[ 60244.267] (EE) 3: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0xbe27) [0x7f61b90339a7]
[ 60244.268] (EE) 4: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x31060) [0x7f61b907db00]
[ 60244.269] (EE) 5: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x3fb73) [0x7f61b909b0c3]
[ 60244.270] (EE) 6: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x3fe1a) [0x7f61b909b77a]
[ 60244.270] (EE) 7: /usr/libexec/Xorg (DamageRegionAppend+0x3783) [0x525003]
[ 60244.270] (EE) 8: /usr/libexec/Xorg (SendGraphicsExpose+0xeb3) [0x4340b3]
[ 60244.270] (EE) 9: /usr/libexec/Xorg (SendErrorToClient+0x2df) [0x43684f]
[ 60244.271] (EE) 10: /usr/libexec/Xorg (remove_fs_handlers+0x453) [0x43a893]
[ 60244.272] (EE) 11: /lib64/libc.so.6 (__libc_start_main+0xf0) [0x7f61be411580]
[ 60244.272] (EE) 12: /usr/libexec/Xorg (_start+0x29) [0x424b79]
[ 60244.273] (EE) 13: ? (?+0x29) [0x29]
[ 60244.273] (EE) 
[ 60244.273] (EE) Segmentation fault at address 0x7f61d93f6160
[ 60244.273] (EE) 
Fatal server error:
[ 60244.273] (EE) Caught signal 11 (Segmentation fault). Server aborting
[ 60244.273] (EE) 
[ 60244.273] (EE) 
Please consult the Fedora Project support 
	 at http://wiki.x.org
 for help. 
[ 60244.273] (EE) Please also check the log file at "/home/mikhail/.local/share/xorg/Xorg.0.log" for additional information.
[ 60244.273] (EE) 
[ 60244.274] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 60244.289] (EE) Server terminated with error (1). Closing log file.
Comment 1 Mikhail 2015-09-21 02:23 EDT
Created attachment 1075388 [details]
dmesg.log
Comment 2 Mikhail 2015-09-21 02:24 EDT
Created attachment 1075389 [details]
system.log
Comment 3 Matej Habrnal 2015-09-23 04:44:11 EDT
Thank you for the bug report.

There is an upstream Git Hub issue related to this bugzilla
https://github.com/abrt/abrt/issues/1023
Comment 4 Matej Habrnal 2015-10-05 04:57:22 EDT
This upstream commit fixes the issue https://github.com/abrt/abrt/commit/0da0e30ce8037934523037d4aec6bb4f44131549
Comment 5 Mikhail 2015-10-06 06:18:13 EDT
Question: Which packages I need install for get full backtrace?
Comment 6 Richard Marko 2015-10-06 07:09:04 EDT
You can use our nightly builds repository:

https://repos.fedorapeople.org/repos/abrt/abrt/fedora-abrt.repo
Comment 7 Mikhail 2015-10-06 07:48:43 EDT
Of course I would use nightly repo.
But, I am still not understand which packages not enough for full backtrace.
I fill my problem here https://bugs.freedesktop.org/show_bug.cgi?id=92062
And Chris Wilson said that my backtrace is useless without relevant debug symbols.
Comment 8 Jakub Filak 2015-10-13 03:45:10 EDT
Mikhail, the report you linked has been created from the logs which were printed out by the crashing Xorg X server process. That means that ABRT cannot get the full backtrace because there is no core dump file to analyze.

I am not sure if the Xorg X server's backtrace printer employs debuginfo packages, so installing Xorg X server debuginfo packages might not help you. But I am sure you should be able to configure Xorg X server to lay a core dump file instead of printing out a backtrace to the logs. Here is the relevant snippet from 'man 5 xorg.conf':

Option "NoTrapSignals" "boolean"
    This prevents the Xorg server from trapping a range of unexpected fatal signals and exiting cleanly. Instead, the Xorg server will die and drop core where the fault occurred. The default behaviour is for the Xorg server to exit cleanly, but still drop a core file. In general you never want to use this option unless you are debugging an Xorg server problem and know how to deal with the consequences.

If you have time and still want to help us, please re-configure your Xorg X server, reproduce the crash and use ABRT to open a new bug report for the crash.
Comment 9 Mikhail 2015-10-15 16:14:35 EDT
I am add NoTrapSignals option to Xorg configuration and after crash occurs again never changed in log files:

[168837.758] (EE) 
[168837.776] (EE) Backtrace:
[168837.779] (EE) 0: /usr/libexec/Xorg (OsLookupColor+0x139) [0x59adf9]
[168837.789] (EE) 1: /lib64/libc.so.6 (__restore_rt+0x0) [0x7f2220ee2b1f]
[168837.797] (EE) 2: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0xaa38) [0x7f221baee1a8]
[168837.798] (EE) 3: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0xbe27) [0x7f221baf09a7]
[168837.799] (EE) 4: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x66893) [0x7f221bba5e33]
[168837.800] (EE) 5: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x68829) [0x7f221bba9d19]
[168837.801] (EE) 6: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x3eda7) [0x7f221bb54f97]
[168837.803] (EE) 7: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x1f7bf) [0x7f221bb1789f]
[168837.803] (EE) 8: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x1f9c2) [0x7f221bb18082]
[168837.803] (EE) 9: /usr/libexec/Xorg (DamageRegionAppend+0x3551) [0x524bc1]
[168837.803] (EE) 10: /usr/libexec/Xorg (SyncVerifyFence+0x1d89) [0x4d7879]
[168837.803] (EE) 11: /usr/libexec/Xorg (SyncVerifyFence+0x36c5) [0x4dad65]
[168837.804] (EE) 12: /usr/libexec/Xorg (SendErrorToClient+0x2df) [0x43684f]
[168837.804] (EE) 13: /usr/libexec/Xorg (remove_fs_handlers+0x453) [0x43a893]
[168837.806] (EE) 14: /lib64/libc.so.6 (__libc_start_main+0xf0) [0x7f2220ece580]
[168837.806] (EE) 15: /usr/libexec/Xorg (_start+0x29) [0x424b79]
[168837.810] (EE) 16: ? (?+0x29) [0x29]
[168837.810] (EE) 
[168837.811] (EE) Segmentation fault at address 0x0
[168837.811] (EE) 
Fatal server error:
[168837.811] (EE) Caught signal 11 (Segmentation fault). Server aborting
[168837.811] (EE) 
[168837.811] (EE) 




# cat /etc/X11/xorg.conf.d/99-server.conf 
Section "ServerFlags"
        Option "NoTrapSignals" "boolean"
EndSection



What I did wrong?
Comment 10 Mikhail 2015-10-15 16:15 EDT
Created attachment 1083395 [details]
journal.log
Comment 11 Mikhail 2015-10-15 16:16 EDT
Created attachment 1083396 [details]
Xorg.log
Comment 12 Mikhail 2015-10-15 17:25:33 EDT
I am sorry I am stupid, I must replace "boolean" with "1".


So, I can catch this now:
https://bugzilla.redhat.com/show_bug.cgi?id=1272250


Thanks!
Comment 13 Mikhail 2015-10-15 17:26:46 EDT
I want to ask it's normal warnings?

$ gnome-abrt 
/usr/bin/gnome-abrt:37: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk

(gnome-abrt:3694): Gtk-CRITICAL **: gtk_header_bar_pack: assertion 'gtk_widget_get_parent (widget) == NULL' failed
Can't open /home/mikhail/.config/abrt/settings/forbidden_words.conf
Can't open /home/mikhail/.config/abrt/settings/ignored_words.conf
Can't open /home/mikhail/.config/abrt/settings/forbidden_words.conf
Can't open /home/mikhail/.config/abrt/settings/ignored_words.conf
Can't open /home/mikhail/.config/abrt/settings/forbidden_words.conf
Can't open /home/mikhail/.config/abrt/settings/ignored_words.conf
Comment 14 Fedora Update System 2015-10-16 15:51:10 EDT
abrt-2.7.0-1.fc23, libreport-2.6.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update abrt libreport'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-cc585b503f
Comment 15 Mikhail 2015-10-19 09:32:07 EDT
Hi. Crash occurs again but gnome-abrt not filled with error report, because in same time crashed google-chrome and seems it DDOS adrt spool. I remember that everytime  chrome cleanup abrt spool when crashed. Can you protect abrt spool from cleaning when huge application such as google-chrome is crashed?
I can fill another bug report if needed.
Comment 16 Mikhail 2015-10-19 09:32 EDT
Created attachment 1084408 [details]
screenshot
Comment 17 Jakub Filak 2015-10-20 01:21:32 EDT
(In reply to Mikhail from comment #15)
> Hi. Crash occurs again but gnome-abrt not filled with error report, because
> in same time crashed google-chrome and seems it DDOS adrt spool. I remember
> that everytime  chrome cleanup abrt spool when crashed. Can you protect abrt
> spool from cleaning when huge application such as google-chrome is crashed?
> I can fill another bug report if needed.

/var/spool/abrt is cleaned because it's disk usage reached the limit configured in /etc/abrt/abrt.conf. Set MaxCrashReportsSize = 0 to stop abrtd from cleaning removing the old problems at all (be sure you clean it sometimes). I use MaxCrashReportsSize = 40000 (40GiB) because I don't want ABRT problems consumed entire disk space.
Comment 18 Mikhail 2015-10-20 17:28:28 EDT
(In reply to Jakub Filak from comment #17)
> /var/spool/abrt is cleaned because it's disk usage reached the limit
> configured in /etc/abrt/abrt.conf. Set MaxCrashReportsSize = 0 to stop abrtd
> from cleaning removing the old problems at all (be sure you clean it
> sometimes). I use MaxCrashReportsSize = 40000 (40GiB) because I don't want
> ABRT problems consumed entire disk space.

I propose to put the protection against removal for unsent bug reports. Because that really annoying when just analyzed report can't be sent because deleted automatically from the disk. Either make the removal of semiautomatic through button, like cleaning  trash in file manager.
Comment 19 Mikhail 2015-10-26 11:06:05 EDT
Jakub, what you think about my proposal?
Comment 20 Jakub Filak 2015-10-26 11:15:40 EDT
(In reply to Mikhail from comment #19)
> Jakub, what you think about my proposal?

I am sorry for being late in replying. I agree with you but it will not be easy to implement. Also, a bugzilla bug requesting this change already exists, I need to dig it up from Bugzilla.
Comment 21 Fedora Update System 2015-10-31 12:08:59 EDT
abrt-2.7.0-2.fc23, libreport-2.6.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.