Bug 126474 - nss_ldap can'n auth on ldaps server
Summary: nss_ldap can'n auth on ldaps server
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nss_ldap   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-22 08:21 UTC by Edy Corak
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 22:40:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Edy Corak 2004-06-22 08:21:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040510

Description of problem:
I use nss_ldap for authentication.

When ssl start_tls is OFF then the authentication works, but
when I turn ssl start_tls then I can not authenticate.

On Fedora Core 1 there was no problem with ssl start_tls





Version-Release number of selected component (if applicable):
nss_ldap-217-1 kernel-2.6.6-1.435

How reproducible:
Always

Steps to Reproduce:
1. turn ssl start_tls in /etc/ldap.conf
2.
3.
    

Additional info:

Comment 1 Edy Corak 2004-06-25 22:40:47 UTC
tls_checkpeer must be set exta to no, because the default dosn't work

# OpenLDAP SSL options
# Require and verify server certificate (yes/no)
# Default is "no" // not ok
#tls_checkpeer yes
tls_checkpeer no // ok

now i can turn ssl start_tls on, work without problems
with my self signed certificate



Note You need to log in before you can comment on or make changes to this bug.