Bug 1264741 - perl-CSS-DOM-0.15-8.fc24 FTBFS: Can't call method "cssText" on an undefined value at t/charset.t line 144
perl-CSS-DOM-0.15-8.fc24 FTBFS: Can't call method "cssText" on an undefined v...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-CSS-DOM (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 02:31 EDT by Petr Pisar
Modified: 2015-11-30 09:36 EST (History)
2 users (show)

See Also:
Fixed In Version: perl-CSS-Dom-0.16-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 09:36:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 107221 None None None Never

  None (edit)
Description Petr Pisar 2015-09-21 02:31:07 EDT
perl-CSS-DOM-0.15-8.fc24 fails to build in F24 because tests fail:

+ make test
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
# "utf-16" is encoded in UCS-2-LE but is not UCS-2-LE-based
Can't call method "cssText" on an undefined value at t/charset.t line 144.
# Looks like you planned 23 tests but ran 9.
# Looks like your test exited with 2 just after 9.
t/charset.t .......................... 
Dubious, test returned 2 (wstat 512, 0x200)
Failed 14/23 subtests 

Difference between working and failing build root:

        perl-Encode 	3:2.76-2.fc24 	> 	3:2.77-1.fc24
	libnghttp2 	1.3.1-1.fc24 	> 	1.3.2-1.fc24
	nss-sysinit 	3.20.0-3.fc24 	> 	3.20.0-4.fc24
	device-mapper 	1.02.107-1.fc24 	> 	1.02.108-1.fc24
	libreport-filesystem 	2.6.2-4.fc24 	> 	2.6.2-5.fc24
	audit-libs 	2.4.3-1.fc24 	> 	2.4.4-2.fc24
	device-mapper-libs 	1.02.107-1.fc24 	> 	1.02.108-1.fc24
	nss-tools 	3.20.0-3.fc24 	> 	3.20.0-4.fc24
	shared-mime-info 	1.4-7.fc24 	> 	1.5-1.fc24
	nss 	3.20.0-3.fc24 	> 	3.20.0-4.fc24
	kernel-headers 	4.3.0-0.rc1.git0.1.... 	> 	4.3.0-0.rc1.git1.1....
Comment 1 Emmanuel Seyman 2015-09-23 11:18:05 EDT
This has been reported to upstream.
https://rt.cpan.org/Ticket/Display.html?id=107221
Comment 2 Emmanuel Seyman 2015-11-30 09:36:14 EST
Upstream has released CSS-DOM 0.16 which fixes this problem.

Note You need to log in before you can comment on or make changes to this bug.