Bug 1264744 - perl-Git-Repository-1.315-1.fc24 FTBFS: t/24-errors.t fails at line 205: doesn't match '(?^:^fatal: bad default revision 'HEAD' )'
perl-Git-Repository-1.315-1.fc24 FTBFS: t/24-errors.t fails at line 205: does...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Git-Repository (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 02:38 EDT by Petr Pisar
Modified: 2015-09-22 04:30 EDT (History)
3 users (show)

See Also:
Fixed In Version: perl-Git-Repository-1.315-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 04:30:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 107219 None None None Never

  None (edit)
Description Petr Pisar 2015-09-21 02:38:36 EDT
perl-Git-Repository-1.315-1.fc24 fails to build in F24 because a test fails:

t/23-quiet.t ............... ok
#   Failed test 'log -1: died'
#   at t/24-errors.t line 205.
#                   'fatal: your current branch 'master' does not have any commits yet at t/24-errors.t line 203.
# '
#     doesn't match '(?^:^fatal: bad default revision 'HEAD' )'
# Looks like you failed 1 test of 65.
t/24-errors.t .............. 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/65 subtests 

Difference between working and failing build root:

        git 	2.5.1-1.fc24 	> 	2.5.2-1.fc24
	git-core 	2.5.1-1.fc24 	> 	2.5.2-1.fc24
	perl-Git 	2.5.1-1.fc24 	> 	2.5.2-1.fc24
	git-core-doc 	2.5.1-1.fc24 	> 	2.5.2-1.fc24
	gnupg2 	2.1.7-1.fc24 	> 	2.1.8-1.fc24

Note You need to log in before you can comment on or make changes to this bug.