Bug 1264753 - [abrt] libreoffice-core: typelib_typedescriptionreference_equals(): soffice.bin killed by SIGSEGV
[abrt] libreoffice-core: typelib_typedescriptionreference_equals(): soffice.b...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephan Bergmann
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:8a92ad454fcac3d9defd19d4f7b...
:
: 1076264 1101563 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 03:06 EDT by Gwendal
Modified: 2016-03-01 04:38 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 04:38:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (60.67 KB, text/plain)
2015-09-21 03:06 EDT, Gwendal
no flags Details
File: cgroup (190 bytes, text/plain)
2015-09-21 03:06 EDT, Gwendal
no flags Details
File: core_backtrace (13.16 KB, text/plain)
2015-09-21 03:06 EDT, Gwendal
no flags Details
File: dso_list (26.91 KB, text/plain)
2015-09-21 03:06 EDT, Gwendal
no flags Details
File: environ (1.64 KB, text/plain)
2015-09-21 03:06 EDT, Gwendal
no flags Details
File: limits (1.29 KB, text/plain)
2015-09-21 03:06 EDT, Gwendal
no flags Details
File: maps (127.85 KB, text/plain)
2015-09-21 03:06 EDT, Gwendal
no flags Details
File: mountinfo (3.42 KB, text/plain)
2015-09-21 03:06 EDT, Gwendal
no flags Details
File: namespaces (85 bytes, text/plain)
2015-09-21 03:06 EDT, Gwendal
no flags Details
File: open_fds (4.15 KB, text/plain)
2015-09-21 03:06 EDT, Gwendal
no flags Details
File: proc_pid_status (1.00 KB, text/plain)
2015-09-21 03:06 EDT, Gwendal
no flags Details
File: var_log_messages (340 bytes, text/plain)
2015-09-21 03:06 EDT, Gwendal
no flags Details

  None (edit)
Description Gwendal 2015-09-21 03:06:18 EDT
Version-Release number of selected component:
libreoffice-core-4.4.5.2-5.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --calc file:///home/ebousse/Documents/Th%C3%A8se/Enseignement/Esir-stages/grille.ods --splash-pipe=5
crash_function: typelib_typedescriptionreference_equals
executable:     /usr/lib64/libreoffice/program/soffice.bin
global_pid:     10995
kernel:         4.1.6-201.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 typelib_typedescriptionreference_equals at /usr/src/debug/libreoffice-4.4.5.2/cppu/source/typelib/typelib.cxx:2297
 #1 operator== at /usr/src/debug/libreoffice-4.4.5.2/include/com/sun/star/uno/Type.h:181
 #2 queryInterface<com::sun::star::uno::XInterface, com::sun::star::uno::XAggregation, com::sun::star::uno::XWeak> at /usr/src/debug/libreoffice-4.4.5.2/include/cppuhelper/queryinterface.hxx:85
 #3 cppu::OWeakAggObject::queryAggregation at /usr/src/debug/libreoffice-4.4.5.2/cppuhelper/source/weak.cxx:292
 #4 ScGridWindow::CreateAccessible at /usr/src/debug/libreoffice-4.4.5.2/sc/source/ui/view/gridwin5.cxx:458
 #5 vcl::Window::GetAccessible at /usr/src/debug/libreoffice-4.4.5.2/vcl/source/window/accessibility.cxx:140
 #6 handle_get_focus at /usr/src/debug/libreoffice-4.4.5.2/vcl/unx/gtk/a11y/atkutil.cxx:524
 #7 WindowEventHandler at /usr/src/debug/libreoffice-4.4.5.2/vcl/unx/gtk/a11y/atkutil.cxx:613
 #8 Call at /usr/src/debug/libreoffice-4.4.5.2/include/tools/link.hxx:139
 #9 VclEventListeners::Call at /usr/src/debug/libreoffice-4.4.5.2/vcl/source/app/vclevent.cxx:62
Comment 1 Gwendal 2015-09-21 03:06:23 EDT
Created attachment 1075391 [details]
File: backtrace
Comment 2 Gwendal 2015-09-21 03:06:24 EDT
Created attachment 1075392 [details]
File: cgroup
Comment 3 Gwendal 2015-09-21 03:06:25 EDT
Created attachment 1075393 [details]
File: core_backtrace
Comment 4 Gwendal 2015-09-21 03:06:27 EDT
Created attachment 1075394 [details]
File: dso_list
Comment 5 Gwendal 2015-09-21 03:06:28 EDT
Created attachment 1075395 [details]
File: environ
Comment 6 Gwendal 2015-09-21 03:06:29 EDT
Created attachment 1075396 [details]
File: limits
Comment 7 Gwendal 2015-09-21 03:06:31 EDT
Created attachment 1075397 [details]
File: maps
Comment 8 Gwendal 2015-09-21 03:06:33 EDT
Created attachment 1075398 [details]
File: mountinfo
Comment 9 Gwendal 2015-09-21 03:06:34 EDT
Created attachment 1075399 [details]
File: namespaces
Comment 10 Gwendal 2015-09-21 03:06:35 EDT
Created attachment 1075400 [details]
File: open_fds
Comment 11 Gwendal 2015-09-21 03:06:36 EDT
Created attachment 1075401 [details]
File: proc_pid_status
Comment 12 Gwendal 2015-09-21 03:06:38 EDT
Created attachment 1075402 [details]
File: var_log_messages
Comment 13 Caolan McNamara 2015-09-21 05:57:50 EDT
caolanm->sberg: is this a duplicate of bug 1247588 ?
Comment 14 Stephan Bergmann 2015-09-21 12:44:38 EDT
The most plausible explanation here is as per <https://gerrit.libreoffice.org/#/c/18750/>.  Lets wait for comments on the questions raised in that upstream patch before backporting.
Comment 15 Stephan Bergmann 2015-09-21 12:49:43 EDT
*** Bug 1101563 has been marked as a duplicate of this bug. ***
Comment 16 Stephan Bergmann 2015-09-21 12:52:05 EDT
*** Bug 1076264 has been marked as a duplicate of this bug. ***
Comment 17 Stephan Bergmann 2015-10-05 08:19:05 EDT
(In reply to Stephan Bergmann from comment #14)
> The most plausible explanation here is as per
> <https://gerrit.libreoffice.org/#/c/18750/>.  Lets wait for comments on the
> questions raised in that upstream patch before backporting.

(will also need upstream follow-up fix for <https://bugs.documentfoundation.org/show_bug.cgi?id=94687> "Calc with GTK3 is freezing")
Comment 18 Stephan Bergmann 2016-03-01 04:38:37 EST
Fixed upstream (see links above) in LO 5.1.0, so fixed in F24.  The problem doesn't look common enough to warrant backporting attempts.

Note You need to log in before you can comment on or make changes to this bug.