Bug 1264774 - yumdownloader --archlist=x86_64 downloads i686 on x86_64
yumdownloader --archlist=x86_64 downloads i686 on x86_64
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: yum-utils (Show other bugs)
7.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Valentina Mukhamedzhanova
Eva Mrakova
:
Depends On: 1165661
Blocks: 1203710
  Show dependency treegraph
 
Reported: 2015-09-21 03:57 EDT by Eva Mrakova
Modified: 2016-11-03 20:13 EDT (History)
5 users (show)

See Also:
Fixed In Version: yum-utils-1.1.31-35.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1165661
Environment:
Last Closed: 2016-11-03 20:13:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eva Mrakova 2015-09-21 03:57:37 EDT
Also happens for
yum-utils-1.1.31-32.el7.noarch

+++ This bug was initially created as a clone of Bug #1165661 +++

Description of problem:
When trying to download x86_64 packages and explicitly using --archlist=x86_64 it also downloads i686 packages.

Version-Release number of selected component (if applicable):
yum-utils-1.1.30-17.el6_5.noarch

How reproducible:
Always

Steps to Reproduce:
# yumdownloader  --archlist=x86_64 glibc
Loaded plugins: product-id, refresh-packagekit, rhnplugin, versionlock
This system is receiving updates from RHN Classic or RHN Satellite.
glibc-2.glibc-2.12-1.132.el6_5.2.x86_64.rpm                              27% [==============-                                       ]  66 kB/s | 1.0 MB     00glibc-2.glibc-2.12-1.132.el6_5.2.x86_64.rpm                              32% [=================-                                    ]  64 kB/s | 1.2 MB     00glibc-2.12-1.132.el6_5.2.x86_64.rpm                                                                                                    | 3.8 MB     01:08     
glibc-2.12-1.132.el6_5.2.i686.rpm 

Actual results:
It downloads the package for all architectures available from repos.

Expected results:
It should only download the x86_64 package, as per the documentation:

$ yumdownloader | grep -A1 archlist
    --archlist=ARCHLIST
                        only download packages of certain architecture(s)
Comment 5 errata-xmlrpc 2016-11-03 20:13:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2187.html

Note You need to log in before you can comment on or make changes to this bug.