Bug 1264836 - The router image name should be ose-haproxy-router
The router image name should be ose-haproxy-router
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade (Show other bugs)
3.0.0
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Scott Dodson
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 06:53 EDT by Anping Li
Modified: 2015-11-19 18:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 18:29:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anping Li 2015-09-21 06:53:51 EDT
Description of problem:
The upgrade script use openshift3/ose-router:v3.0.2.0 as router_image. The correct image name should be 'openshift3/ose-haproxy-router:v3.0.2.0'

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. install openshift v3.0.1.0
2. upgrade using ansible
ansible-playbook openshift-ansible/playbooks/adhoc/upgrades/upgrade.yml



Actual results:
Upgrade used the non-exsit image 'openshift3/ose-router:v3.0.2.0'.

TASK: [debug var=router_image] ************************************************ 
ok: [192.168.1.101] => {
    "var": {
        "router_image": "openshift3/ose-router:v3.0.2.0"
    }
}


Expected results:
Upgrade script should use 'openshift3/ose-haproxy-router:v3.0.2.0'.
In upgrade.yml line 57,  it should be  "replace( '${component}', 'haproxy-router' ) 


Additional info:
Comment 1 Scott Dodson 2015-09-21 12:51:14 EDT
Thanks for testing, I've updated the image name, please pull the latest and re-test.
Comment 2 Anping Li 2015-09-21 21:36:35 EDT
Verified and pass
The image name have been updated.

TASK: [debug var=router_image] ************************************************ 
ok: [192.168.1.101] => {
    "var": {
        "router_image": "openshift3/ose-haproxy-router:v3.0.2.0"
    }
}
Comment 4 errata-xmlrpc 2015-11-19 18:29:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:2492

Note You need to log in before you can comment on or make changes to this bug.