Bug 1264849 - RFE : Create trash directory only when its is enabled
RFE : Create trash directory only when its is enabled
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: trash-xlator (Show other bugs)
mainline
All All
medium Severity medium
: ---
: ---
Assigned To: Jiffin
: FutureFeature, Triaged
Depends On:
Blocks: 1319485 1324531 1415581
  Show dependency treegraph
 
Reported: 2015-09-21 07:18 EDT by Jiffin
Modified: 2017-05-30 14:32 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.11.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1324531 1415581 (view as bug list)
Environment:
Last Closed: 2017-03-03 03:49:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiffin 2015-09-21 07:18:51 EDT
Description of problem:

The creation of trash directory will performed only when it is enabled. And similarly operations such as rename , deletion will be prevented only when it is enabled. If creation fails (by some how) then trash xlator will off by throwing a warning message. The same is applicable for internal op directory.
Comment 1 Vijay Bellur 2015-10-12 09:00:59 EDT
REVIEW: http://review.gluster.org/12256 (features/trash : create trash directory only when it is enabled) posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 2 Vijay Bellur 2016-03-28 05:44:13 EDT
REVIEW: http://review.gluster.org/12256 (features/trash : create trash directory only when it is enabled) posted (#3) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 3 Mike McCune 2016-03-28 18:50:27 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Niels de Vos 2016-05-10 05:32:09 EDT
This didnt make it for GlusterFS 3.8, moving out of the tracking tree.
Comment 5 Worker Ant 2016-08-29 16:09:42 EDT
REVIEW: http://review.gluster.org/12256 (features/trash : create trash directory only when it is enabled) posted (#4) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 6 Worker Ant 2016-08-30 02:50:58 EDT
REVIEW: http://review.gluster.org/12256 (features/trash : create trash directory only when it is enabled) posted (#5) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 7 Worker Ant 2016-12-14 04:33:07 EST
REVIEW: http://review.gluster.org/12256 (features/trash: Create trash directory only when it is enabled) posted (#6) for review on master by Anoop C S (anoopcs@redhat.com)
Comment 8 Worker Ant 2016-12-21 00:37:43 EST
REVIEW: http://review.gluster.org/12256 (features/trash: Create trash directory only when it is enabled) posted (#7) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 9 Worker Ant 2016-12-22 00:28:40 EST
REVIEW: http://review.gluster.org/12256 (features/trash: Create trash directory only when it is enabled) posted (#8) for review on master by Anoop C S (anoopcs@redhat.com)
Comment 10 Worker Ant 2017-01-17 02:01:45 EST
REVIEW: http://review.gluster.org/12256 (features/trash: Create trash directory only when it is enabled) posted (#9) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 11 Worker Ant 2017-01-18 07:39:28 EST
REVIEW: http://review.gluster.org/12256 (features/trash: Create trash directory only when it is enabled) posted (#10) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 12 Worker Ant 2017-01-19 10:16:03 EST
REVIEW: http://review.gluster.org/12256 (features/trash: Create trash directory only when it is enabled) posted (#11) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 13 Worker Ant 2017-01-20 07:12:25 EST
COMMIT: http://review.gluster.org/12256 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 07b9853ad0c92b341be33a6cd632013c416221c8
Author: Jiffin Tony Thottan <jthottan@redhat.com>
Date:   Mon Sep 28 17:20:19 2015 +0530

    features/trash: Create trash directory only when it is enabled
    
    Previously trash directory was being created as part of volume
    start operation. And also the user/admin could not delete this
    directory from volume even if it is not needed. This patch will
    fix the same. From now onwards creation and enforcement on trash
    directory will come into pictrure only when trash translator is
    enabled. Similarly exact same behaviour is reflected on internal-op
    directory inside trash directory.
    
    Change-Id: I3e58316a7b299a691885e458c960438bec2220fb
    BUG: 1264849
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/12256
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: Anoop C S <anoopcs@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Anoop C S <anoopcs@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 14 Shyamsundar 2017-05-30 14:32:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.