Bug 1264851 - XMLRPC search for bug_status=['NEW'] returns HTTP error 502
XMLRPC search for bug_status=['NEW'] returns HTTP error 502
Status: CLOSED DUPLICATE of bug 1266261
Product: Bugzilla
Classification: Community
Component: Internal Tools (Show other bugs)
4.5
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 07:22 EDT by Ilya Etingof
Modified: 2017-07-06 21:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 00:49:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bugzilla XMLRPC request data (1.67 KB, text/plain)
2015-09-21 07:22 EDT, Ilya Etingof
no flags Details

  None (edit)
Description Ilya Etingof 2015-09-21 07:22:34 EDT
Created attachment 1075473 [details]
Bugzilla XMLRPC request data

We have a script that watches relevant bugs in Bugzilla. For that it periodically runs specific XMLRPC query against production Bugzilla. It worked till last week when Bugzilla has been upgraded.

Now it still works unless 'NEW' is present in input 'bug_status' array. With 'NEW' there it always fails with 502 error code.

Please, see reproducer request in attachment. It fails unless you remove 'NEW' from it.
Comment 1 Matt Tyson 2015-09-22 02:53:35 EDT
This looks like a proxy timeout.

Can you attach your script so that I can see your exact search terms?
Comment 3 Jason McDonald 2015-09-25 00:49:30 EDT
This has been narrowed down to a specific issue with searching on the short_desc field, reported in Bug 1266261.

*** This bug has been marked as a duplicate of bug 1266261 ***

Note You need to log in before you can comment on or make changes to this bug.