Bug 1264937 - bogus obsoletes/provides
bogus obsoletes/provides
Status: CLOSED DUPLICATE of bug 1261034
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 13:08 EDT by Ralf Corsepius
Modified: 2015-09-30 04:47 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 04:47:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2015-09-21 13:08:44 EDT
Description of problem:
	
dnf-plugin-system-upgrade tries to obsolete fedup, but lacks the required 
Provides: fedup = ...

Version-Release number of selected component (if applicable):
dnf-plugin-system-upgrade-0.4.1-1.fc22

Actual results:
The broken obsolete/provides result into this absurd behavior:

# dnf install fedup
...
Installing:
 fedup                           noarch    0.9.2-1.fc22
...

# dnf update
Last metadata expiration check performed 0:12:28 ago on Mon Sep 21 17:30:31 2015.
Dependencies resolved.
========================================================================================================================================
 Package                                              Arch                      Version                         Repository
========================================================================================================================================
Installing:
 dnf-plugin-system-upgrade                            noarch                    0.4.1-1.fc22                    updates
     replacing  fedup.noarch 0.9.2-1.fc22
 python2-dnf-plugin-system-upgrade                    noarch                    0.4.1-1.fc22                    updates

Transaction Summary
========================================================================================================================================
Install  2 Packages

Total download size: 70 k
Installed size: 130 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): python2-dnf-plugin-system-upgrade-0.4.1-1.fc22.noarch.rpm                                                 391 kB/s |  25 kB     0
(2/2): dnf-plugin-system-upgrade-0.4.1-1.fc22.noarch.rpm                                                         579 kB/s |  44 kB     0
----------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                             30 kB/s |  70 kB     0
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Installing  : python2-dnf-plugin-system-upgrade-0.4.1-1.fc22.noarch
  Installing  : dnf-plugin-system-upgrade-0.4.1-1.fc22.noarch
  Obsoleting  : fedup-0.9.2-1.fc22.noarch
  Verifying   : dnf-plugin-system-upgrade-0.4.1-1.fc22.noarch
  Verifying   : python2-dnf-plugin-system-upgrade-0.4.1-1.fc22.noarch
  Verifying   : fedup-0.9.2-1.fc22.noarch

Installed:
  dnf-plugin-system-upgrade.noarch 0.4.1-1.fc22                       python2-dnf-plugin-system-upgrade.noarch 0.4.1-1.fc22

Complete!



Expected results:
dnf-plugin-system-upgrade to 
Provides: fedup = <version > last released version of fedup in fedora>
Comment 1 Ralf Corsepius 2015-09-23 13:45:08 EDT
Seems as if I didn't look carefully enough:

dnf-plugin-system-upgrade seems to provide sufficient Obsoletes/Provides

# rpm -q --provides dnf-plugin-system-upgrade
dnf-command(system-upgrade)
dnf-plugin-system-upgrade = 0.4.1-1.fc22
fedup = 0.9.3-1

# rpm -q --obsoletes dnf-plugin-system-upgrade
fedup < 0.9.3-1

So, ... I am inclined to consider the behavior above to be a defect in dnf.
Comment 2 Rex Dieter 2015-09-23 15:52:37 EDT
Similar issue as bug #1261034 it seems
Comment 3 Honza Silhan 2015-09-30 04:47:15 EDT

*** This bug has been marked as a duplicate of bug 1261034 ***

Note You need to log in before you can comment on or make changes to this bug.